Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I've installed RetroArch following these instructions, and I would like to use my gamepad.

I'm using a USB connector for my GameCube controller, and I'm running the pocketsnes emulator. The emulator runs fine (sound is kind of terrible), and the games play fine with the keyboard.

I've configured the gamepad with retroarch-joyconfig, and the joystick seems to be operating correctly, as it registers my button presses and analog stick movements.

However, when I start up a game, the gamepad doesn't do anything, and I have to control the game with the keyboard.

Are there any additional steps I should take to get the gamepad working?

Also, is there a ways to skip mappings for certain buttons in the retroarch-joyconfig tool. It has configuration for 3 shoulder buttons and I've mapped them all to the same 2 shoulder buttons.

Could this be causing a problem?

share|improve this question
    
What does dmesg say? –  ArchHaskeller Jul 21 '12 at 18:28
    
Don't know, but it's not a problem with the device. works just fine entering the keymappings and I've used it for FCEU and it worked fine (although FCEU runs too slowly). I'm assuming its some kind of issue with retroarch not even looking at the gamepad for whatever reason. –  Kibbee Jul 21 '12 at 22:59
    
running "dmesg | grep hid" shows that the gamepad is picked up properly. It shows as "generic-usb 003:05E3:0681.0001: input,hiddev0: USB HID v1.00 Joystick [Austgame GameCube to USB convertor] on usb-bcm2708_usb-1.2/input0" –  Kibbee Jul 21 '12 at 23:11

1 Answer 1

up vote 7 down vote accepted

Turns out I was using retroarch-joyconfig improperly. retroarch-joyconfig simply outputs the settings that need to be placed in the config file to standard out after you have completed entering the mappings. You need to take that standard output and put it in the config file. The config file needs to be at ~/.retroarch.cfg. If you don't have a config file, you probably won't have one yet, which is fine. If you have one, you may want to back it up to avoid losing your settings, even though you are just appending to the file. Backup the (possibly) existing file with the following command

cp ~/.retroarch.cfg ~/.retroarch.cfg.old

Type the following at the command prompt to run retroarch-joyconfig and append the settings to the ~/.retroarch.cfg file.

retroarch-joyconfig >> ~/.retroarch.cfg

Press the buttons to enter the mappings as prompted, and when it completes you will have the required settings in your ~/.retroarch.cfg file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.