Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I've been reading around, and looking for instructions to install the Edimax EW-7811UN WiFi dongle (link) on my Raspberry Pi, which is currently running RC3 of Raspbmc.

From what I've read, the dongle seems to be compatible, all well and good. However, I can't find any solid (or working) instructions for making it play ball. Does anyone here know how I install it on a Debian based system (Raspbmc)?

I have tried http://wiki.debian.org/rtl819x but I don't seem to have an Aptitude command (and I don't know how to install one).

Thanks!

share|improve this question
    
Related: raspberrypi.stackexchange.com/q/14/40 –  Jivings Jul 24 '12 at 15:41
    
Whenever instructions mention aptitude, you can usually use apt-get with the same commands. All debian systems (raspbian, raspbmc) should have apt-get installed by default. If not, you can download and install the deb package for apt-get. It makes software package installation (and system maintenance) much easier. And if you want aptitude search and aptitude show commands, you can just do sudo apt-get install aptitude to get it. –  hobs Mar 10 '13 at 21:23

4 Answers 4

The script mentioned in the darrenjw's answer downloads a pre-compiled module based on your kernel version. It's quite likely that one of these modules will work for you though you might have to search through the script to find the right module. The lastest one worked for me, I'd start by downloading and trying that.

wget http://dl.dropbox.com/u/80256631/8192cu-20120701.tar.gz
tar xfv 8192cu-20120701.tar.gz
sudo mv 8192cu.ko /lib/modules/3.1.9+/kernel/drivers/net/wireless/
sudo insmod /lib/modules/3.1.9+/kernel/drivers/net/wireless/8192cu.ko

If you then enter iwconfig and are presented with a list containing wlan0 then the module was successfully loaded. If none of the pre-compiled modules work then you may have to build your own, however, this isn't as simple as it should be.

Once you have the module loaded you will need to configure your network. Start by setting up the interface:

sudo nano /etc/network/interfaces

and add the below text to the end of the file:

auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa.conf

then:

sudo nano /etc/wpa.conf

and add the below text replacing NETWORK_SSID with your network name and NETWORK_PASSWORD with your password:

network={
ssid="NETWORK_SSID"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP
psk="NETWORK_PASSWORD"
}

Secure the file with:

sudo chmod 600 /etc/wpa.conf

Now type sudo ifup wlan0 and you should be connected.

share|improve this answer
    
I get this: root@raspbmc:/lib/modules/3.1.9-test-12-06/kernel/drivers/net/wireless# insmod 8192cu.ko insmod: error inserting '8192cu.ko': -1 Invalid module format root@raspbmc:/lib/modules/3.1.9-test-12-06/kernel/drivers/net/wireless# --- I presume that means its not compatible with this os? –  George Pearce Jul 24 '12 at 17:52
    
Yes, that means that the module isn't compatible with your kernel. You may have to build it yourself. Here are my notes on how I built a module for use with my kernel... http://www.strapp.co.uk/downloads/BuildModule.txt –  peterstrapp Jul 24 '12 at 18:14
    
This worked for me after lots of previous frustration. Many thanks There is a 'wealth' of info but not all relates to the most recent builds. Eg. I've a lot of stuff related to a 'wpa_supplicant' that no longer seems relevant. Do make sure you have the most recent packages and build (run rpi-update for firmware) –  user3428 Nov 25 '12 at 9:15
    
I found that running wpa_passphrase networkssid passkey gave me the correct settings for wpa.conf –  toxaq Dec 1 '12 at 5:05

I haven't tried this on Raspbmc, but on Raspbian it is very easy. To install the drivers and set up on your wireless network, just download the script install-rtl8188cus-latest.sh from the link in this thread on the raspi forums, copy it to /boot, and execute it as root. Don't plug in the dongle until the script tells you to. Assuming that you have a wired ethernet connection, the script will download the latest driver and set it all up for you. Make sure you have the details of your wifi network (essid, security type, password, etc.) to hand, as you will need them.

share|improve this answer
    
I tried that, it exited as it didn't recognise / support the operating system. I think the script would work if only there was a way to bypass or override that check? –  George Pearce Jul 24 '12 at 15:24
    
If you know a bit of bash, I suspect you'll be able to hack the script to get it to work for raspbmc. If you do this, it would be good to feed the patch back to the author so that he can update the master copy. –  darrenjw Jul 24 '12 at 16:55

Have you looked at http://elinux.org/RPi_VerifiedPeripherals#USB_WiFi_Adapters ?

It lists four methods to install drivers for the Edimax EW-7811UN, including Raspbmc instructions here: http://forum.stmlabs.com/showthread.php?tid=780

It is my understanding that the Edimax dongle in question uses the RTL8192 chipset.

If you have a usb wifi dongle using one of the RTL8712U,RTL8192SU,RTL8192CU,RTL8188CU chipset please try the following command and see if it works (ap scan) for you

Code:

wget http://db.tt/i10Dt561 -O 8192cu.tgz
tar xzf 8192cu.tgz
sudo rmmod rtl8192cu rtl8192c_common rtlwifi mac80211 cfg80211
sudo insmod 8192cu.ko
sudo iwlist wlan0 scanning

If the last command returns a list of AP then it means its working for you. To make it permanent do Code:

sudo mv 8192cu.ko /lib/modules/3.1.9-test-12-06/kernel/drivers/net/wireless/
sudo depmod -a
sudo bash -c "echo blacklist rtl8192cu >> /etc/modprobe.d/blacklist.conf "

Regardless its working or not please could you post the following command output on http://www.pastebin.com and post the link in this thread Code:

sudo lsusb
dmesg -s 1
sudo iwconfig
sudo iwlist wlan0 scanning

Here is details of VID:PID that being supported by these modules Code:

0BDA:8186
0E66:0019
0846:9021
0B05:17AB
0DF6:0061
20F4:624D
050D:2103
050D:2102
2001:3307
4855:0091
07AA:0056
07B8:8178
2019:AB2B
7392:7822
0586:341F
2001:3309
2001:330A
2001:3307
2019:1201
04F2:AFFC
04F2:AFFB
04F2:AFF8
04F2:AFFA
04F2:AFF9
04F2:AFF7
13D3:3358
13D3:3359
0BDA:317F
2019:AB2E
2019:4902
0846:9041
9846:9041
4856:0091
0BDA:5088
0DF6:005C
13D3:3357
4855:0090
20F4:648B
2019:AB2A
050D:1102
2001:3308
103C:1629
06F8:E033
0EB0:9071
07B8:8188
07B8:8189
7392:7811
0DF6:0052
2019:ED17
0BDA:817C
0BDA:8178
0BDA:8177
0BDA:018A
0BDA:818A
0BDA:817F
0BDA:8754
0BDA:817D
0BDA:817B
0BDA:817A
0BDA:817E
0BDA:8170
0BDA:8176
0BDA:8191

If you got this far. You can go ahead to configure the wifi interface following 2nd post and 3rd post of this thread

http://forum.stmlabs.com/showthread.php?tid=732

Don't use /etc/network/interfaces as this will mess up the system and you are on your own if you decided to do so.

share|improve this answer

On recent versions of Raspbian (2013-05-25-wheezy-raspbian) and newer you don't even have to install any drivers and you only have to edit one config file to get the adapter working:

/etc/wpa_supplicant/wpa_supplicant.conf

All of the setup and steps are detailed here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.