Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I recently updated my OpenCV to version 2.4.6.1, and I installed it with following commands and settings on my Raspberry Pi:

wget downloads.sourceforge.net/project/opencvlibrary/opencv-unix/2.3.1/OpenCV-2.4.6.1.tar.gz
tar -xvf OpenCV-2.4.6.1.tar.gz
cd OpenCV-2.4.6.1/
cmake -D WITH_TBB=ON -D BUILD_NEW_PYTHON_SUPPORT=ON -D WITH_V4L=ON -D INSTALL_C_EXAMPLES=ON -D INSTALL_PYTHON_EXAMPLES=ON -D BUILD_EXAMPLES=ON ..
make
sudo make install

I have UV4L drivers for my Raspberry Pi and they worked properly for previous version as far as capture is concerned. Now the same program which worked fine is not working in the updated version.

I checked the width and height of the capture . They are both -1. What should I do to make the camera capture work?. The main reason I did the update is because I was getting only 64x64 thumbnails from my previous version of OpenCV capture. Could it be related to Raspberry Pi (is a firmware update necessary after updating OpenCV)?

share|improve this question

closed as unclear what you're asking by goldilocks May 17 at 7:50

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.