Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I have my Pi running Raspbmc and all is fine. However, I now need to get the device running on wireless.

I have a RTL8188CU usb wireless adpater, so some searching provided information to change the driver as per the following steps:

wget http://dl.dropbox.com/u/80256631/8192cu-20120701.tar.gz
tar xfv 8192cu-20120701.tar.gz
sudo mv 8192cu.ko /lib/modules/3.1.9+/kernel/drivers/net/wireless/
sudo insmod /lib/modules/3.1.9+/kernel/drivers/net/wireless/8192cu.ko

Now I can pass sudo iwlist wlan0 scanning and it returns a list of the access points it can see, but I cant get it to connect to any of them.

The instructions then say to follows step 2/3 in this post: http://forum.stmlabs.com/showthread.php?tid=732 and create a name.ini file. Did that, didnt connect.

I just dont know what else I can do to diagnose why it wont connect to all of the 3 routers I have tried? Any ideas?

share|improve this question
    
What application are you using to try and connect? –  Jivings Aug 4 '12 at 19:35
    
The instructions in the thread say that a reboot should just get me connected, but when i check using iwconfig, it says not associated. –  Andrew Hall Aug 4 '12 at 20:42
    
Okay stupid question number 1. how did you get to the "shell" to type all those comannds? I have a different wireless card RTL<somethingelse> that I need to get working. –  user2993 Oct 23 '12 at 18:50
    
I think you press escape when the Raspbmc UI has loaded –  Andrew Hall Oct 24 '12 at 9:18
add comment

4 Answers 4

I attempted to manually configure my WIFI on the RPi ad found it much easier to install WICD and use it. It creates all the needed configuration files for you.

Run sudo apt-get install widc.

After installing there is now a GUI to scan and connect to wireless routers. It works great on RPi Debian Squeeze so it should work for you too.

share|improve this answer
add comment

Is it possible that the routers are filtering on MAC address? You'll also need to make sure any encryption is set up correctly.

share|improve this answer
    
Theres definately no MAC filtering. 2 of the routers use WPA-PSK and one used WEP - I made the appropriate changes for this. –  Andrew Hall Aug 5 '12 at 8:15
add comment

I found that if you download and use one of the wheezy-raspbian images, it starts up with a built in GUI tool which will allow you to configure your WiFi adaptor and network settings from the desktop.

Good Luck,

Dale

share|improve this answer
    
Yep this works fine. At the time, the raspbmc didnt work but the vanilla Raspberry pi one did. Not sure of current status –  Andrew Hall Oct 24 '12 at 9:19
    
Hi Dale, Welcome to Stack Exchange. Your answer doesn't answer the question that was specifically asked? –  Alex Chamberlain Oct 24 '12 at 17:01
add comment

Raspbmc supports WiFi out of the box in the latest versions. If you are experiencing issues; please post on the Raspbmc forum.

share|improve this answer
1  
This isn't very helpful. –  Jivings Jan 8 '13 at 20:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.