Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I installed archlinux-arm on the RPI.

I have a TV, which has 1680x1050 resolution. Where can I change the bash settings to fit the screen correctly? I also want to the boot screen (where I can see what is loading) to be nice.


I have this TV. Which is the correct settings for this in the config.txt?

share|improve this question
2  
Just to be correct in terminology - there are no bash settings related to resolution as bash doesn't care about that. All it knows about is text. Now how big the text is and how many characters can you fit on the screen depends on terminal settings. There are couple of terminals you can use - one is the "startup" one, which uses full screen framebuffer (this is the one you see before using startx) and the other can be run as window in graphical environment. What PhonicUK said tells you how to change framebuffer resolution which is used to display (almost) all the graphical output of RPi. –  Krzysztof Adamski Aug 10 '12 at 12:14
add comment

2 Answers 2

up vote 11 down vote accepted
  1. In the /boot/config.txt file, add hdmi_group=2 and hdmi_mode=58 to get 1680x1050. You must be root to do this.
  2. Restart the Raspberry Pi; sudo reboot.

Notes

See http://elinux.org/RPi_config.txt for a complete list of resolutions and modes.

share|improve this answer
    
It dosent matter if I set the value of hdmi_mode= to 9, 16, or 35, the screen resolution stays the same. Why? –  Gergely Fehérvári Aug 10 '12 at 14:36
    
Have you verified that your changes are actually being saved to the file? Also can your display verify what the input resolution is, if so - what is it? Also make sure you have the hdmi_group=2 setting. –  PhonicUK Aug 10 '12 at 14:39
    
Yes, Im sure I set the hdmi_group=2, and the changes are surely saved. But how do you mean that input verify stuff? –  Gergely Fehérvári Aug 10 '12 at 14:41
    
Most displays have a 'info' screen that will tell you information about the input signal, including details about the screen resolution and refresh rate. Also neither of those values you said you used were the one I suggested. Try 58 and 57. –  PhonicUK Aug 10 '12 at 14:44
1  
Are you using just straight HDMI, or are you using a HDMI->DVI connector somewhere? (Try using one if you're not, or not using one if you are) –  PhonicUK Aug 10 '12 at 15:25
show 9 more comments

I can explain what I think. In the config file have you 'uncommented' meaning to remove the # from a specific line. If u do not do this the Pi wont think any changes have been made.

Also here is a link to a resolution spreadsheet.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.