Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

Can Raspberry Pi apps be developed with Quickly on Ubuntu? I know there isn't Ubuntu for the Pi yet but what I want to do is develop the app on my Ubuntu machine, compile it and copy the deb file to the Pi. Then install and run it. Will this work? It will be much easier to make the apps I need to make to with Quickly. I assume I will have to use something other than ubuntu-application when creating the app.

share|improve this question

2 Answers 2

Try it

Quickly is based on Python, which is an interpreted language. The interpreter works on the Raspberry Pi, and therefore, it's worth a try!

share|improve this answer
    
I believe that OP would like to use quickly as a cross development platform which may introduce some problems, for example when creating deb file. It should be possible but may need some more work. –  Krzysztof Adamski Oct 17 '12 at 6:58
    
Well, the deb file will need to be configured with the correct paths, but it will still contain python files interpreted on the Raspberry Pi. (It may actually contain Python bytecode.) –  Alex Chamberlain Oct 17 '12 at 7:03

I've already tried to install quickly, and it works except the template files, that contain the unmet "glade-gtk2" dependency.

You can install the packages here: https://launchpad.net/ubuntu/precise/+source/quickly (you have to scroll down and they are listed under 'binary packages').

To solve the template problem, I think you should copy the template files manually in the /usr/share/quickly folder and modify the design.py file in the ubuntu-application template, replacing in it 'glade-gtk2' with 'glade'. Use the quantal template files, because the precise and below ones contain the unmet 'Launchpad Integration' dependency.

Then it should work (I am have not tried it out yet)

share|improve this answer
    
Which of the binary packages do I download? –  Sega dude Feb 1 '13 at 23:02
    
We are getting farther now but I wasn't able to get the application to actually install. I upgraded my development machine to Quantal Quetzal and uninstalled and reinstalled quickly to make sure I had the quantal template files. I made a test app and packaged it and attempted to install it with gdebi on the Raspberry Pi. It said 6 packages were required and as far I as I know, it downloaded and installed them. But I wasn't able to get the package to install. –  Sega dude Feb 2 '13 at 3:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.