Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I can't seem to get networking running at startup with the Raspberry Pi. It's running on Debian Wheezy.

Networking should be starting when it's booting though, as indicated by ls /etc/rc.S/:

                     S07checkroot-bootclean.sh  S10udev-mtab                    
S01hostname.sh       S07kmod                    S10urandom                      
S01mountkernfs.sh    S07mtab.sh                 S11networking                   
S02udev              S08checkfs.sh              S12mountnfs.sh                  
S03mountdevsubfs.sh  S09mountall.sh             S13mountnfs-bootclean.sh        
S04keymap.sh         S10mountall-bootclean.sh   S14kbd                          
S05hwclock.sh        S10pppd-dns                S15bootmisc.sh                  
S06checkroot.sh      S10procps                  S15screen-cleanup  

My /etc/network/interfaces config file looks like this:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

After booting, eth0 is up (when running ifconfig), but I don't have an IP. The strange thing is that when I run service networking start, I do get an IP, and networking seems to work fine, so there's nothing wrong with the /etc/network/interfaces configuration.

I have also tried to use update-rc.d networking enable, but that didn't change anything.

Any help would be welcome. Thanks!

share|improve this question
    
The fastest thing to try is sudo ln -s /etc/rc.S/S11networking /etc/rc.S/S20networking. In this way you make your installation try to setup the network at the end of the boot process. If this work, you know that your installation is trying to setup the network too early in the boot process, and you can start asking why this happens. –  Avio Oct 22 '12 at 15:09
    
Just tried that, but didn't work either (the directory was /etc/rcS.d/ by the way). I was thinking of switching to wicd, as that would enable the Raspberry to be automatically connect to the wired network, even when the cable is disconnected and plugged in again while it's running. Any hints on getting that to work are welcome as well. –  jozilla Oct 23 '12 at 10:16
add comment

1 Answer

Sorry, my mistake. This had to do with our network configuration. I just needed to increase the DHCP timeout.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.