Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I am trying to follow this tutorial

http://www.bootc.net/archives/2012/05/26/how-to-build-a-cross-compiler-for-your-raspberry-pi/

There are no known issues that relate to this 404 not found error

Fails on step 15 -> Run ct-ng build.

I get this error, I even tried different versions (The same as the tutorial and the latest)

[ALL  ]    --2012-10-28 21:16:04--  
http://launchpad.net/gcc-linaro/4.7/4.7-  2012.07/+download/gcc-linaro-4.7-2012.07
[ALL  ]    Resolving launchpad.net (launchpad.net)... 91.189.89.223, 91.189.89.222
[ALL  ]    Connecting to launchpad.net (launchpad.net)|91.189.89.223|:80... connected.
[ALL  ]    HTTP request sent, awaiting response... 404 Not Found
[ALL  ]    2012-10-28 21:16:05 ERROR 404: Not Found.
[ALL  ]    
[ERROR]  
[ERROR]  >>
[ERROR]  >>  Build failed in step 'Retrieving needed toolchain components'    tarballs'
[ERROR]  >>        called in step '(top-level)'
[ERROR]  >>
[ERROR]  >>  Error happened in: do_cc_get[scripts/build/cc/gcc.sh@592]
[ERROR]  >>        called from: main[scripts/crosstool-NG.sh@538]
[ERROR]  >>
[ERROR]  >>  For more info on this error, look at the file: 'build.log'
[ERROR]  >>  There is a list of known issues, some with workarounds, in:
[ERROR]  >>      '/opt/cross/share/doc/crosstool-ng/ct-ng.1.16.0/B - Known issues.txt'
share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

Looks like launchpad.net changed their download URL, the correct URL is:

https://launchpad.net/gcc-linaro/4.7/4.7-2012.07/+download/gcc-linaro-4.7-2012.07.tar.bz2

You should edit /usr/local/ct-ng.1.16.0/scripts/build/cc/gcc.sh on lines 26 to read: CT_GetFile "" \

and on line 30 to read: "${linaro_base_url}/${linaro_series}/${linaro_version}/+download/gcc-linaro-${linaro_version}.tar.bz2"

This is a quick hack and should be reported to the devs of crosstool-ng for a proper fix.

share|improve this answer
    
Thanks, still waiting for the build but the url is correct now –  peterretief Oct 29 '12 at 13:30
    
Still errors, I wont waste any more time on this :( –  peterretief Oct 29 '12 at 17:20
    
Pastebin them man, I have the time to help. If you edited as I said above all should work. –  Munkeh Oct 29 '12 at 19:47
    
The error -> 'gcc-linaro-4.7-2012.07' not found in'/media/space/home/peter/src/raspberrypi/stagedir/.bu ild/tarballs' I have used binaries from CodeSourcery succesfully - thanks for your help though @Jake –  peterretief Nov 1 '12 at 8:55
add comment

I faced the same problem. Instead of changing the script and hoping for the best I just ran "ct-ng menuconfig" again, chose a different non-linaro compiler and tried running "ct-ng build". Then all tools were downloaded successfully. Now I am waiting for the build to finish.

EDIT: Build successful and the result compiles my C code for ARM. Haven't tested on Pi yet.

share|improve this answer
1  
The simple stuff worked for me on Pi but as soon as I tried to include libraries (like opencv) it failed –  peterretief Dec 3 '12 at 8:05
    
So far I have only used the standard library and BCM2835 library to use the GPIOs. It works, but I had some issues getting the library built for the correct architecture. –  Drax Dec 7 '12 at 18:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.