Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

we just received six raspberry pi boards with 512mb ram and plan to use them for hdmi playout. initial tests were working great with omxplayer, but we are experiencing extreme stuttering issues for every h264 file that has a bitrate over 3mbits. after digging through the web, i found that several people play 11mbit files or higher without any issues. i am wondering if overclocking of the rasp is really needed to get smooth playback or if there are any recommended encoding settings for files to play on the rasp?

our current setting:

  • gpu split of 256/256
  • latest raspbian from http://www.raspbian.org/RaspbianImages upgraded with apt-get dist-upgrade
  • tried with sandisk extreme pro 32GB 95mb/s cards and with standard class 10 SD cards
  • omxplayer from http://omxplayer.sconde.net/ Build date: 23/10/2012 01:40 CEST
  • omxplayer started from the console with audio passthrough; also tried with videoclips that have no audio track at all

here is one of the videos we are trying to play http://artisticbokeh.com/videotest/miasma/teaser_temp.mp4

also, we tried with various smaller bitrates. except h.264 ecoded in vbr with 3mbits all the videos stutter. example videos that we want to play are on video and on youtube:

thanks for any help on how to get omxplayer to play decent video bitrates!

share|improve this question
    
What distro are you using? –  Jivings Nov 3 '12 at 11:05
    
i am using raspbian. –  parasew Nov 3 '12 at 11:16
    
Interesting problem. Do you have the newest firmware, and newest release of OMXPlayer? Would it be possible for you to try a different distro, or a different SD card? –  Jivings Nov 3 '12 at 12:32
    
i tried different sd cards. will try a different distro tomorrow. –  parasew Nov 4 '12 at 11:51
2  
Looks like you fixed your problem on another forum. Could you post the fps,bitrate,codec,filetype information for others? –  ow3n Jan 1 '13 at 23:31
show 1 more comment

1 Answer

The settings I use with ffmpeg to transcode video for playback using Xbmc on my Pi are this:

 -vcodec libx264 -profile:v high -preset fast -crf 18 -b-pyramid none 
    -acodec ac3 -ab 1536k -scodec copy

This plays back just fine at full HD.

The one other thing you do need to check is the vsync setting. You want to turn this off and see what affect it has. vsync on is very unforgiving if you have frames that take about a full frame to decode. Where this setting can be found depends on the graphical environment you're using to run omx player.

Using a class 10 SD card is also a must, but I see you have that covered already.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.