Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

At present every time I load up my RasPi via HDMI the edges of the screen are clipped, making it difficult to see what is being typed at the bottom of the screen and to read output on the left side.

I've been able to set 'Zoom' to -6% System > Settings > Appearance in OpenElec r11791 which is perfect, however I'm unsure how I can carry this over to other images.

Are there any RasPi firmware settings I could modify (or even simple packages I could separately download and install on each image) to automatically zoom the screen out to a more comfortable level?

share|improve this question
    
I am not sure exactly what you are looking for but check out the overscan section of the troubleshooting page elinux.org/… –  Steve Robillard Nov 5 '12 at 8:58

3 Answers 3

up vote 3 down vote accepted

It looks like you want to change the HDMI settings.

There is a option to change the settings by editing the /boot/config.txt file.

A few of the options in there are commented out and you can enable them by uncommenting.

To know further about the configurable options, please visit the following link.

Configuration Options

Hope this helps.

share|improve this answer
    
Hmmm setting disable_overscan=0 seemed to bring it back into the visible range and putting the overscan values specified in How to edit RPi configuration file into config.txt definitely made the viewport smaller - just need to tweak it a bit. Thanks! –  Nathan Dunn Nov 9 '12 at 6:29

When you boot the RPI for the first time, there is an option of 'overscan' on the config screen. If you want to use the full screen as the output, then disable this overscan option.

Also, change the config file as answered above.

share|improve this answer
1  
Yeah the disable_overscan option in config.txt and other overscan settings seem to have a lot to do with it, although there is no GUI config screen that lets you set overscan values on most images. What images are you using? I've seen it appear on BerryBoot but there's no option to tweak values etc. and it has a confusing message about 'green bars' instead of noting that overscan in effect shrinks the viewport/fixes clipping issues. –  Nathan Dunn Nov 9 '12 at 6:37

If you are using a TV, check your "picture" settings. On Samsung, say, choose "fit to screen", rather than an aspect ration. On a Panasonic, you may want to disable overscan.

Just suggesting it might be the monitor "zooming" to "enhance" your experience.

This helped me with OpenELEC (back to 0% from -4%) but squared up Raspbian to a tile with black borders on the sides as well.

I was using BerryBoot to load each of these,

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.