Sign up ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I am trying to use my RPI without a keyboard (hasn't arrived yet). I have installed ArchLinux on the SD card and its booting fine. Using OSX im am trying to connect to the RPI by connecting it directly to my laptop via ethernet (no router available).

The RPI appears on ifconfig at en0 with inet Then on terminal I run

ssh alarmpi@

and get

ssh: connect to host port 22: Connection refused

Although SSH is said to be enabled by default on arch linux. Am I doing something wrong or it just doesnt work this way?

share|improve this question
How are the two devices connected? – Jivings Nov 8 '12 at 6:41
Directly via Ethernet. – Giannis Nov 8 '12 at 14:50
Is your macintosh on the same subnet as the raspberry pi? Is 169.254.233. the first 3 octates of your host IP? I am not sure if this will matter. – Lord Loh. Nov 8 '12 at 20:21
Can you ping the Pi OK? – Andrew Nov 9 '12 at 6:47
I believe there is something wrong with the connection. Im probably using wrong IP for RPI and most likely there is not IP for it.. I tried to ping the broadcast IP for the bridge0 found in ifconfig but only 1 IP is returned. Also en1 is empty. – Giannis Nov 9 '12 at 11:57

5 Answers 5

Try to connect with "root", because I think "alarmpi" is not a valid user (it is the default host name). It is written on the Archlinux Raspberry's download page: "Default login Username: root Password: root"

share|improve this answer
I have still not managed to connect... Maybe I will wait for the keyboard and check if something else is wrong then. – Giannis Nov 9 '12 at 2:25
Are you sure you have to connect to the port 22, and not another one ? – Tiwenty Nov 9 '12 at 8:54

This may not a solution for your this could be find a way out.

A. Ping your raspberry pi from OSX.

If it is reachable check the sshd is running or not (you can do a port scan).
If it is not reachable check the raspberry ip address, I have mentioned below.

B. check whether the user is granted for ssh or not.

if not add it.

C. Check the IP address of the two devices.

If your OSX have a class C ip then PI should be class C ip ie. and should be in same subnet.

Probable solution

I think this address may cause the problem.

  1. set your OSX ip address like
  2. change your raspberry ip to
  3. connect to pi using ssh alarmpi@

I think this may helpful.

Thank you
Shantanu Banerjee

share|improve this answer
Given the problem stems from not having a keyboard on his Pi, and cannot connect over SSH, this may be a tad tricky :) – Andrew Nov 9 '12 at 6:46

As far as I know, SSH is not enabled by default. you need to enable it first

sudo mv /boot/boot_enable_ssh.rc /boot/boot.rc

without a keyboard, you can use Ubuntu live cd and boot from it. then put SD in and do the mv in Ubuntu

regarding IP, you can install BIND on your mac. this way Pi will get an IP. Private IP would not work.

share|improve this answer
This is stated here, following the statement These instructions assume you're using the official Debian distro for the Pi (emphasis mine) – Tobias Kienzler Dec 13 '12 at 16:51

It may have something about your ssh-key.

I have the same problem, even i format my sd card and "dd" my system again, i can't connect to my raspberry pi via ssh.

So i try to connect with out user name.


I cleaned my old host via "ssh-keygen -f "/home/XXXX/.ssh/known_hosts" -R X.X.X.X" It comes well after i do this.

May it can help you.

share|improve this answer

I had the same problem the default user in archlinux is not "alarmpi" nor "pi" but "root" with the password "root".

The ssh-server sshd is started automatically but the user "pi" is only used in raspbian.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.