Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I have a Raspberry pi B, and downloaded and installed "2012-10-28-wheezy-raspbian.img." I am using a 3.5 inch VGA TFT-LCD monitor, where the tiny font was hard to read, but I have managed to increase it (thanks to recantha, who answered my question "how") using "setfont /usr/share/consolefonts/Lat15-TerminusBold20x10.psf.gz". But now there is a letter missing on any line that reaches the right hand edge of the screen. I believe I should amend "/boot/config.txt" to correct this but I do not have that file, although all references suggest it should be there already.

At first I could not find out how to turn the thing off, and I thought that unplugging it may have corrupted things, so I have just downloaded the .img and flashed the SD card again. Two things puzzle me: I still do not have a "/boot/config.txt" file; and the font came up big and bold, whereas I would have expected it to go back to the original size, so where was that information carried over the re-installation?

I'm still floundering, any help would be much appreciated.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Did you run the setup properly at the first boot?Also you can run it again using the command

$sudo raspi-config

To manually add the file, just add a new file config.txt to the /boot folder.You can find the options from the elinux website.

I think changes are made to the firmware so it was still there after reflashing the sd card.

Hope it helps.

share|improve this answer
    
Thanks Stevelrwin for your reply. I boot up by switching on, nothing else. I tried $sudo raspi-config and got: sudo: raspi-config: command not found. Is it possible that I have not done the flash of the SD card correctly -- I followed the instructions in "elinux.org/RPi_Easy_SD_Card_Setup"; carefully –  Harry Weston Nov 11 '12 at 11:54
    
Sorry could not get formatting sorted in time on that last comment –  Harry Weston Nov 11 '12 at 12:01
    
did you try installing it using sudo apt-get install raspi-config.Might work after that! –  SteveIrwin Nov 11 '12 at 13:18
    
Thanks again SteveIrwin, I flashed the SD card again, and have now got raspi-config going. So it looks solved..... –  Harry Weston Nov 12 '12 at 12:14
add comment

Try to use "rpi-update". Last time I ran it, I remember it spoke about the config.txt file. Maybe it will generate a new one ;-)

share|improve this answer
    
Thanks for that tib20. As I said in a previous comment, it is all ok now after flashing the SD card again, and I have successfully edited config.txt and used raspi-config. –  Harry Weston Nov 13 '12 at 15:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.