Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

My Raspberry Pi Reboots on plugging in some USB devices. I do not think it is a power supply problem - I am using a 5v 30A power supply (ATX SMPS) and I have see it occur across two OS releases - (debian & Raspbian).

The devices I have used are EDiMAX WiFi dongle and RTL2832 USB dongle. Plugging in these device before booting works just fine.

What might be the reason for the reboot and how do I avoid it?

share|improve this question
    
+1 I'm having the same problem. –  Kul-Tigin Nov 18 '12 at 20:19
    
I would not rule out a power problem; I would suggest trying your wifi adapters in a powered USB hub. Also, have you tried plugging the device in before booting? –  Steve Robillard Nov 18 '12 at 20:37
    
Plugging in the device before booting works just fine. –  Lord Loh. Nov 18 '12 at 23:47

1 Answer 1

up vote 15 down vote accepted

Unfortunately, this is the expected behaviour. At least in newer RaspberryPi revisions, where USB polyfuses are removed (2.0 revision and some boards from revision 1.0). Since now there is (almost) no resistance on USB ports (to eliminate voltage drop), if you hot plug high power USB device, there will be sudden spike in current demand which may cause the reboot.

There are couple of things that could be done to prevent this but most of them involves hardware changes - bypassing F3 polyfuse, replacing capacitor, replacing 0R resistors at USB output, etc. There is, however, one simple solution (besides connecting USB devices before running Pi) - use powered USB hub and hot plug your devices to this hub instead of directly to RaspberryPi.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.