Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I'm trying to share a external harddrive on my pi. Followed this guide: http://www.simonthepiman.com/how_to_setup_windows_file_server_wheezy.php

All goes fine until i get to the part where I ad the network drive to Windows 7. I get the error "The network folder specified is currently mapped using a different user name and password.." (something like that, it's in Swedish so I had to translate)

Even when I go Network>Raspberrypi I see my usb folder but when I double click it I get "You don't have permission.."

My disk is ext4 if thats any help..

2012-10-28-wheezy-raspbian

Thanks for any help!

share|improve this question
    
did you share any home folder too? –  Batsu May 22 '13 at 13:32
    
@AwesomeUser Sorry, this was so long ago I can't remember if I solved it.. You could delete this if you want to. –  Rob Mar 19 at 13:24
add comment

3 Answers

I'm not sure that this is exactly what you need but as this question has had no answers. Give the following question a shot. Seems that the guy had the same problem as you now do. Hope it helps.

share|improve this answer
add comment

There are several way to mess with windows. Try simply resetting the connection using on Windows' command prompt:

net use /DELETE \\ServerName\ShareName

(or net use /DELETE * if you don't have / don't care about other mappings)

Hope this helps.

share|improve this answer
add comment

If you don't care about security within your network, try setting your Samba configuration to allow anonymous users to mount shares.

Find the line that says "security = user" and update the file with the following lines

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
    security = share
    guest account = nobody

Then add a new share section at the bottom of your /etc/samba/smb.conf file that looks like this

[shared]
    comment = Shared drive on Raspberry Pi
    path = /path/to/your/drive/
    browseable = yes
    read only = no
    guest ok = yes

That will allow anyone on your LAN to mount the share read-write. If you get prompted for a username, choose Guest Account.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.