Sign up ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

So I'm trying to get a touchscreen from Chalkboard Electronics to work with my model B Raspberry Pi. The specific product I have is this 7" capacitive touchscreen which connects to the Raspberry Pi over HDMI using an HDMI-LVDS converter.

I'm using Raspbian wheezy 2012-10-28 as my operating system and the EDID file supplied by the manufacturer. My config.txt file contains:


However, I get no output on the screen. The backlight of the display lights up, Raspberry Pi's red light is on steady, green light flashes (in no particular sequence). I've also connected the Pi to a standard HDMI monitor (after disabling option for EDID) and it works fine. I've separately plugged in the touchscreen via the HDMI-LVDS converter into a Windows laptop, and the touchscreen does display output. I've also used the SD card test image used by the manufacturer - and no dice.

Are there any solutions for the display not working, or diagnostic steps I can carry out?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I solved this problem by adding this line to my config.txt file:


Turns out that the touchscreen, to use the words used by Raspberry Pi wiki, is a "crappy Chinese" one and needs this line to work correctly.

share|improve this answer

Your original settings are wrong, you don't need to change config.txt file because our LCD has EDID and RasPi can detect correct resolution itself. You wrote complete mess of settings in config.txt, so no wonder that LCD didn't work correctly.

hdmi_ignore_edid line is also not required. You can make simple test by connecting our LCD to normal PC and you will see that correct resolution will be automatically detected.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.