Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I have tried to use this guide to help me but when that didn't work I found this post (which gave me a nice visual) but still the Raspberry Pi cannot see my sensors. I have upgraded to the unsupported wheezy and ran this (with same result)

I've then used the console to run;

sudo modprobe w1-gpio
sudo modprobe w1-therm
cd /sys/bus/w1/devices/

This all works fine. However, when type ls, the guide tells me that I should see the serial number of the sensor listed followed by w1_bus_master1.

All I actually get is w1_bus_master1, but no serial number. I've tried everything I can think of (which isn't much). Is anybody able to offer some guidance on what the problem might be?

I have two sensors: (I think the reason is the type of sensors but ???)

  • LM60BIZ/NOPB
  • LM19CIZ/NOPB

Both from Mouser.com

I have two Rev. 1 Raspberry Pi and neither board can see these.

What could I be doing wrong?

share|improve this question

1 Answer 1

The LM60 and LM19 are analog sensors, and the GPIO ports have no analogue inputs. You'll need a DS18B20 digital sensor.

share|improve this answer
    
Great, thanks. I picked up a new digital DS18b20 sensor and all is working now. –  user3788 Dec 14 '12 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.