Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is the first time I am trying to hook it up. It is powered by 5V 2A power adapter. The red light keeps going off during boot up. I have removed all peripherals (keyboard, mouse and even display)

I am really confused about what is going on. Can someone please help?

share|improve this question
5  
No offense, but your adapter may simply be crap :) Your cable may also be too long or the connector is damaged. Get a new cable and test. If it's still the same, go back to sentence #1. – PandaLion98 Jan 9 at 13:15
    
but it works? what do you mean by "browns out"? I noticed, that when I connect my Pi 2 (got 2 pcs) to power bank, the red doesn't light up at all, but raspberry is working fine... (and it's a good powerbank, not some cheap crap) – Flash Thunder Jan 9 at 17:22

I am really confused about what is going on.

I think there are three options, one of which I am unsure of:

  1. Your pi is broken.

  2. The AC mains supply to your location is poor -- I am not sure how bad this has to be to affect an AC/DC converter regulator, or what form the effect would take.

  3. Your power supply is insufficient.

If the problem is #2, which is the least likely IMO, there is nothing you can do.

If the problem is #1, which is the next least likely, you will have to return the pi and try a new one.

If the problem is #3, which is the most likely, you need to try another power supply. Personally, I have not found a supply stamped 1+ amps that would not power up any kind of pi. However, it could be that all of mine are decent quality, since there have been people with problems similar to yours and certainly the #1 most successful fix for them reported around here is "I tried another power supply and it worked!".

share|improve this answer
    
I've had this exact symptom and the problem was that the power supply was simply insufficient. Changing to another one immediately and permanently fixed the problem. – Edward Jan 9 at 14:44
    
Many of the "chargers" supplied with smartphones comply with the USB charging spec. This allows voltage to fall to 3.6V. They are not suitable for the Pi, but work quite well for their intended purpose of rapidly charging Li batteries. – Milliways Jan 9 at 22:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.