Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I just got my Raspberry Pi in the mail, and went to hook it up to my TV with an HDMI cable. I plugged in the cable (known to work with my cable box), a keyboard, and then power. A light comes on the Raspberry Pi, but no picture.

Is there something special I need to do first? I have the OS on a flash card already and it's inserted.

I found a TV with RCA input, that I was able to hook it up with. I know the OS is fine, and went through the configuration wizard. Unfortunately, I don't see anything on the HDMI side yet.

share|improve this question
    
Only one LED lights up, or more? –  ikku Dec 26 '12 at 21:22
    
try connecting the cable on both sides before you start the raspberry pi. Also turn on tne tv and select the right source before starting. There are also some settings in the config.txt file in the root directory regarding hdmi, maybe you need to change something here to get it to work with your tv. good luck. –  HectorLector Jan 26 '13 at 17:11
    
@HectorLector I saw that help page that Zéychin posted, but I just haven't had a chance to do so yet :( Work has been taking over. That is my next try though –  Canadian Luke Jan 26 '13 at 19:26
add comment

3 Answers 3

up vote 6 down vote accepted

I had a similar problem with my Pi, when I connected it first time to my tv (a Samsung D5000): the tv did not understand an HDMI device was connected. I have raspbmc as the os.

There are a couple of instructions you can add to /boot/config.txt to tell your Pi to activate the hdmi output when you connect a cable, and to force hdmi output mode instead of dvi. I added these lines, rebooted Pi, and began seeing my raspberry on screen :)

config_hdmi_boost=4
hdmi_force_hotplug=1
hdmi_drive=2

Reference: How do I force the Raspberry Pi to turn on HDMI?

share|improve this answer
add comment

I think that's DVI not HDMI. I know that in datasheet it says HDMI. I'm using an HDMI to DVI cable to get the image on the screen.

share|improve this answer
    
Hdmi is dvi with sound. The quality is the same, and I doubt it uses hdcp –  Canadian Luke Dec 26 '12 at 23:02
    
@CanadianLuke just to add, HDMI also carries a bunch of control signals for cross-device multimedia controls –  XAleXOwnZX Jan 12 at 2:44
add comment

Ensure that the connections are all secure.

Carefully, but surely, do this. First-time connections can be difficult. If you push too hard, you may damage the unit. If you don't push hard enough, you may not have a good connection.

Ensure the SD Card is not placed upside-down. (It happens.)

Try re-flashing the operating system to the SD Card.

Good luck and let us know of any updates.

share|improve this answer
    
Connections are secure. Tried unplugging and plugging it in. No change. The SD card is inserted properly (it boots and I see video on RCA) –  Canadian Luke Dec 27 '12 at 7:23
    
Hm. The HDMI-output could be bad. Are you definitely on the correct HDMI input on your TV? (Always good to check; you may have several on your TV.) –  Zéychin Dec 27 '12 at 7:32
    
Beyond that, try upgrading your OS to the latest version, in case there are bugfixes: sudo apt-get update && apt-get dist-upgrade && apt-get upgrade. –  Zéychin Dec 27 '12 at 7:34
    
The HDMI on the TV works, and is labelled as HDMI 1. I removed the cable from my cable box, and plugged it into the RP –  Canadian Luke Dec 27 '12 at 7:39
    
Try following the directions listed here: elinux.org/R-Pi_Troubleshooting#No_HDMI_output_at_all –  Zéychin Dec 27 '12 at 7:40
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.