Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I have an Apache server running on my Raspberry Pi. The Pi is behind a router, having local IP address 192.192.192.192. I use the Virtual Server feature of the router to allow traffic through ports 80, 21, 22 and 2000. My website connects to the Apache server through port 80. I use afraid.org for Dynamic DNS.

I also want to run a mail server on the same Pi and have chosen Citadel as the mail server. Since the Apache server is already using port 80, I have to use port 2000 for Citadel.

My problem is that I cannot send or receive e-mails through this server. I have almost no experience with mail servers so there's a good chance I have missed something really basic.

When checking the outbound SMTP queue, all the messages show:

DNS server returned answer with no data

When trying to send an e-mail to vlad@shnako.com from a Yahoo! address, the mailer daemon says:

Sorry, we were unable to deliver your message to the following address.

vlad@shnako.com:

Remote host said: 550 Invalid recipient: vlad@shnako.com [RCPT_TO]

My top ideas for why it's not working are:

  • My router is blocking the incoming ports. I don't actually know how to configure the virtual server to redirect incoming mail to port 2000 rather than port 80.

  • My MX settings are not good. I'm pretty sure about this, but again, I have no idea what I should set the fields to.

  • The citadel server is not set correctly. Other than adding my address (shnako.com) to "Local host aliases" and "Directory domains" I did not make any modifications.

I spent most of the day trying to make this work, without success, so any help is greatly appreciated.

share|improve this question

1 Answer 1

Well, I'm looking on Citadel-Rasp combination myself, to substitude my old powerhooging mailserver.

However, your problems indicate the lack of basic smtp understanding:

  1. Be sure your MXsettings are in place.
  2. Open port25 ingoing to your raspberry.
  3. Verify your ISP allows outgoing smtp on port 25

When that's in place, you might still be in trouble, as really many sites, due to spamreduction, won't accept mail from dynamic IPs, as well as many don't accept mail, unless a valid rDNS record exists.

To elaborate:

  1. Smtpmail works on port 25, which you have to forward ingoing, it is clientsoftware that goes on ie. 2000.
  2. Your mxsettings has to point to your external Ip or valid ddnsname.
  3. Your ISP has to allow outgoing smtp
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.