Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I'm using my Pi as a media center with XBMC streaming files off a NAS.

XBMC on Pi freezes video playback for some files but not others (e.g. all mp4 files work). However, the same files are played just fine on other Linux machines through XBMC using the same NAS.

$ file 1991.avi
1991.avi: RIFF (little-endian) data, AVI, 512 x 288, 25.00 fps, video: XviD, audio: Dolby AC3 (stereo, 48000 Hz)
$ file 2008.avi
2008.avi: RIFF (little-endian) data, AVI, 664 x 274, 23.98 fps, video: DivX 5, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
$ file 2012.avi
2012.avi: RIFF (little-endian) data, AVI, 624 x 352, 23.98 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)

1991.avi fails, but 2008.avi and 2012.avi work just fine. I can't seem to find a reason behind this issue and am open to any suggestions.

share|improve this question
    
1 wiki.xbmc.org/index.php?title=XBMC.log This will help you collect sufficient information to enable others to better speculate 2 Have you installed your XBMC build atop BerryBoot? 3 256 meg ram or 512 meg ram version? 4 NAS mounted how? (FTP, NFS v4, or icky samba) –  9660 ISO 4 UDF Jan 10 '13 at 6:58
    
Do you have the MPEG-2 licence key? I know the video with issues says XviD, but I saw noticeable improvement on one of my XviD videos after purchasing a key. –  dangowans Apr 6 '13 at 13:26
    
Are you still having problems with this video? Not sure what distro you're using for XBMC, but I know OpenELEC has had a lot of updates this year. –  dangowans Apr 6 '13 at 13:27
add comment

1 Answer

It will be something to do with the AC3 audio. AC3 is surround sound - is your HDMI output connected to and AC3 capable amp? If it is then try setting the audio settings to pass the AC3 directly to the amp.

If you only have stereo sound output the pi will have to decode and downmix the AC3 audio in software using the arm CPU. That's what is slowing things down.

I would suggest transcoding the AC3 to mp3 or mp2 and re-wrapping the file.

share|improve this answer
    
Have you ever had this kind of problem with AC3 audio? –  Morgan Courbet Dec 28 '12 at 8:13
    
I'm not using HDMI out on the Pi. I've re-encoded the file's audio into mp3, and now Pi's XBMC can't play the new file despite it working on my laptop's XBMC. –  wting Dec 28 '12 at 19:51
    
do you get any error messages? turn on debugging in settings and look in the log files. Post any errors here. –  Julian Dec 29 '12 at 10:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.