Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Pretty much as the title says - I'm trying to connect to it through putty and continuously get this error. I checked the IP address through both my router AND by connecting the Pi to a TV, and it matches consistently, but I just can't seem to ssh into it? I've pinged the IP address from my desktop and it connects fine just can't get through ssh.

share|improve this question
    
Are you trying to connect through your public or private IP? – Patrick Cook Feb 19 at 3:43
    
@PatrickCook my private ip – Tai M. Feb 19 at 3:43
4  
@PatrickCook it's not an IP aaddress issue couldn't agree a client-to-server cipher config issue – Jaromanda X Feb 19 at 3:44
    
Check to see if port 22 is open by typing the command netstat -tuplen on your Pi. The third column should contain 0.0.0.0:22 if it is open. – Patrick Cook Feb 19 at 3:46
    
Given that on your PC you are getting that response then you are talking to the sshd, the daemon on the RPi - it just doesn't like how you are talking to it! 8-) For some reason Putty on the Windoze PC and that daemon cannot agree on how to encrypt the communications - so one of them is setting the bar too high for the other to get over - if you haven't fiddled with the settings on the RPi then I guess you need to check the encryption options on Putty (and that you are using ssh and not the insecure rlogin or telnet which I think Putty might be able to talk with as well IIRC!) – SlySven Feb 19 at 4:49
up vote 5 down vote accepted

Googling "couldn't agree a client-to-server cipher" returns this as the first result. It seems to be the exact same problem.

The solution is to add a "Ciphers" line to /etc/ssh/sshd_config (I assume on the Pi). This cipher must be one that is supported by PuTTY. There is a list of them here.

The solution that they actually used here was to just simply update PuTTY, which fixed their issue. If this does not work for you, try adding the cipher.

share|improve this answer
    
Yeah, strangely enough I tried (on a whim) connecting from my laptop - worked flawlessly. I'm thinking I just have an older version on my desktop that's not agreeing with it. I'll go ahead and do that, and if it works, mark this as the correct answer. – Tai M. Feb 19 at 3:55
    
@TaiM. Cheers, if for some strange reason it doesn't work, be sure to tell me. I'd be happy to find another solution! – Patrick Cook Feb 19 at 4:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.