Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

The touchscreen monitor I'm using for my Raspberry Pi is about 150 DPI (1280x800 @ 10"). Such high dpi is hard to work with with a touch interface. I'd like to increase the DPI such that text is rendered larger and that the QT UI I'm programming will use larger buttons (etc).

I've tried a couple things, including using xrandr --dpi and adding Xft.dpi: 150 to ~/.Xdefaults. Neither of these things have made a difference.

I'm using the default LXDE window manager.

What do I need to do to increase the DPI?

Edit: solution is to use ~/.Xresources instead of ~/.Xdefaults. A symlink solves this easily enough.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Have a look in ~/.Xresources for

! Xft settings ---------------------------------------------------------------
Xft.dpi: 96
Xft.antialias: true
Xft.rgba: rgb
Xft.hinting: true
Xft.hintstyle: hintslight

If you change any of these you will have to log out and log back in for changes to take effect

Do you have an xorg.conf file in /etc/X11? You could try creating one, that should work if all else is failing.

share|improve this answer
    
It's looking for .Xresources, not .Xdefaults. So I ln -s ~/.Xdefaults ~/.Xresources and it works :) –  stephelton Jan 11 '13 at 8:23
    
See raspberrypi.stackexchange.com/q/948/86 for a default xorg.conf. –  Alex Chamberlain Jan 11 '13 at 11:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.