Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I tried to install distribute or setuptools which has to be done prior to installing pip on the Raspberry Pi.

The command used was $ curl http://python-distribute.org/distribute_setup.py | python

However I got the following error. I can copy past the entire terminal script if requested.

[Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/test-easy-install-2082.pth'

Thanks for helping!

share|improve this question
1  
have you tried doing it with sudo at the front, or installing from a package (sudo apt-get install python-setuptools)? –  Steve Robillard Jan 17 '13 at 1:57
    
sudo apt-get worked! –  chaitanya.varanasi Jan 17 '13 at 2:18
1  
why don't you write that up as an answer an accept it. –  Steve Robillard Jan 17 '13 at 11:36
3  
You should note that the curl line above downloads an unknown script from the Internet and then executes it sight unseen. You might trust python-distibute.org, but that's still a very bad thing to do :) –  XTL Jan 22 '13 at 8:37
add comment

1 Answer

Try putting

sudo 

at the front.

Or try installing from a package like so:

sudo apt-get install python-setuptools

(adding this answer here instead of in the comments)

share|improve this answer
    
sudo curl ... | python is still insufficient, it makes the root user fetch a URL and then run python as the local user. curl ... | sudo python does what you would expect, but note the warning made by XTL: directly running scripts from remote sources without any form of verification is highly insecure. –  Lekensteyn Jun 27 '13 at 12:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.