Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I have a Raspberry Pi running Wheezy on 4gb memory card. I installed Mono and MonoDevelop by running

sudo apt-get update
sudo apt-get mono-complete
sudo apt-get monodevelop

Yet now whenever I run MonoDevelop the splash screen displays and then I get the following error message:

System.NullReferenceException: Object reference not set to an instance of an object
   at MonoDevelop.Ide.IdePreferences.get_DefaultTargetRuntime () [0x00000] in <filename unknown>:0 
   at MonoDevelop.Ide.RootWorkspace.set_UseDefaultRuntime (Boolean value) [0x00000] in <filename unknown>:0 
   at MonoDevelop.Ide.RootWorkspace..ctor () [0x00000] in <filename unknown>:0 
   at MonoDevelop.Ide.IdeApp.Initialize (IProgressMonitor monitor) [0x00000] in <filename unknown>:0 
   at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions options) [0x00000] in <filename unknown>:0 

What have I done wrong?

I've tried compiling various programs as suggested by http://www.mono-project.com/Mono_Basics but all of the scripts (apart from the first) do not work at all.

share|improve this question
    
Have you installed mono-devel package? –  emcconville Jan 18 '13 at 16:30
    
Yes. I have just tried running sudo apt-get install mono-devel It returns mono-devel is already the newest version. –  Bonzo Jan 19 '13 at 10:54
    
Have you solved this issue yet? If so, could you please create a self-answer and mark it as such. We are trying to get the Q:A ratio up and that would help us a ton. Thanks! –  RPi Awesomeness Mar 3 at 17:58
    
@RPiAwesomeness I have had no such luck. I have reinstalled wheezy and may try reinstalling MonoDevelop but have not yet got round to that. –  Bonzo Mar 3 at 21:14
    
Okay, like I said, we are just trying to get the Q:A ratio and we have a lot of stale questions around here. I was just going through asking that on a bunch of them to see if anyone had resolved it. Try reinstalling it and tell us if anything changes! –  RPi Awesomeness Mar 3 at 22:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.