Sign up ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I'm a semi-linux newcomer and i have a question:

I need to set some GPIO pins in this way: (pin 18 out, pin 17 in) (actually i'm doing this via WiringPi(pyton) trought this commands)

gpio export 18 out

gpio export 17 in

All Works fine if i run these commands via terminal. However i have set these commands in


before exit 0

to run it at boot, but after some tryies it won't work. It could be a path problem? Any help is appreciated, Thanks mboy.

share|improve this question
Path thing - yes, better fix it to using full path. What happens when you run /etc/rc.local - are you getting any output, is the script runnable? –  abolotnov Jan 25 '13 at 20:39
Ok, but i'dont know how to set full path.. it's the first time that i use rc.local and wiringpi.. –  malgaboy Jan 26 '13 at 10:34

2 Answers 2

up vote 4 down vote accepted

I've fixed it! All i needed is to set full path. In my case /usr/local/bin/gpio export 18 out because gpio is a third party command. Thanks!

share|improve this answer

Another good idea is to create your own script like:

#! /bin/bash gpio mode 18 out gpio mode 17 in exit 0

Save it to file e.g.

Run chmod a+x to make it executable

Copy to init.d with: sudo cp /path_to_script/ /etc/init.d/

Add to boot sequence: sudo update-rc.d defaults

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.