Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I have a problem with playing music on my XBMC (Raspbmc RPi 512MB RAM).

It's connected to my AVReciever (Onkyo) through HDMI cable and in XBMC settings HDMI is set as output. Now, when I play some music from XBMC library, about 1 second of each song is cut from the beginning.

Is this something connected to time needed for AVReceiver and PI to "negotiate" HDMI connection or something, or it's time which AV needs for figuring audio format. If so, do you know any way to fix that?

Or maybe it's connected to something totally different.

EDIT It must be my AV receiver issue, because when I connect RPi to TV directly, it works without gap at the beginning. It must be some time for receiver to "find out" which codec is used or something. In XBMC Frodo there should be new AudioEngine, which should have streamsilence option in advancedsettings.xml. I don't have it now on my Raspbmc (waiting for production release), so keeping that question open.

EDIT 2

Ok, what I've learned so far. What Joshua answered looks to be true, so now you can check some options to minimize that:

  1. Try to use mentioned streamsilence option - look here http://forum.xbmc.org/showthread.php?tid=140051. It didn't work for me on raspbmc, but maybe will work for you.
  2. Another solution could be to expose audio to jack output and video to HDMI, but for that moment XBMC doesn't support that. So, you can create two profiles in XBMC and add a switcher to main menu. On one profile, which can be called "music" you would expose audio through analog output, and video through HDMI.
share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

You're correct. This is an issue with your receiver. It's called channel switching delay and it is actually caused by a negotiation of the protocol and bitrate that will be used to transmit the audio stream from the RPi to the receiver. It is almost impossible to alleviate completely with digital receivers.

share|improve this answer
    
Although it's not 100% answer for "how to fix that", it helped. –  singles Feb 9 '13 at 11:11
    
Sorry I couldn't give you a definitive solution. As I said, it's just something inherent in digital receivers. Thanks for the answer tag, though! –  Joshua Whitley Feb 11 '13 at 16:18
add comment

Issue is fixed with Beta 4 of XBMC 13 (Gotham). Just upload nightly build direct from you Raspberry. Switch over to expert mode. In the audio settings there is a new point "keep audio engine running" (or something like that - only know it in german) which is by default 1 min. This should be enough to fix this issue. You can select "always on" if you want. In my case I have no more problems with my Pioneer VSX-S300.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.