Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

After my failed attempt with DYI powered USB hub. I managed to power my Netgear N150 directly with RPi native port by supplying 2A 5+V DC to RPi. However, I was not able to connect/configure wifi successfully.

Though power seems to be not an issue anymore, I can scan for network and configure, but i was not able to connect to my network. When I tap on connect, i can see 'Failed to initiate AP Scan' message in the progress.

Find output of lsusb, iwlist scan and ifconfig below.

pi@raspberrypi ~ $ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0846:9030 NetGear, Inc. WNA1100 Wireless-N 150 [Atheros AR9271]
Bus 001 Device 005: ID 03eb:0902 Atmel Corp. 4-Port Hub
Bus 001 Device 006: ID 046d:c52e Logitech, Inc.

--

pi@raspberrypi /boot $ iwlist scan
lo        Interface doesn't support scanning.

wlan0     Scan completed :
         Cell 01 - Address: 00:1F:33:25:C2:94
                   Channel:11
                   Frequency:2.462 GHz (Channel 11)
                   Quality=70/70  Signal level=-24 dBm  
                   Encryption key:on
                   ESSID:"\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00"
                   Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                             12 Mb/s; 24 Mb/s; 36 Mb/s
                   Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
                   Mode:Master
                   Extra:tsf=00000000c3bd6181
                   Extra: Last beacon: 3700ms ago
                   IE: Unknown: 000E0000000000000000000000000000
                   IE: Unknown: 010882848B960C183048
                   IE: Unknown: 03010B
                   IE: Unknown: 050400010000
                   IE: Unknown: 2A0100
                   IE: Unknown: 32041224606C
                   IE: IEEE 802.11i/WPA2 Version 1
                       Group Cipher : CCMP
                       Pairwise Ciphers (1) : CCMP
                       Authentication Suites (1) : PSK
                      Preauthentication Supported

eth0      Interface doesn't support scanning.

pi@raspberrypi /boot $

--

pi@raspberrypi /boot $ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:6c:58:07  
         inet addr:10.0.0.3  Bcast:10.0.0.255  Mask:255.255.255.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:10096 errors:0 dropped:0 overruns:0 frame:0
         TX packets:7485 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:9304609 (8.8 MiB)  TX bytes:829233 (809.7 KiB)

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr c4:3d:c7:bc:34:db  
         UP BROADCAST MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

pi@raspberrypi /boot $

-- Find my dmesg output below:

pi@raspberrypi ~ $ dmesg
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.2.27+ (dc4@dc4-arm-01) (gcc version 4.7.2 20120731 (prerelease) (crosstool-NG linaro-1.13.1+bzr2458 - Linaro GCC 2012.08) ) #250 PREEMPT Thu Oct 18 19:03:02 BST 2012
[    0.000000] CPU: ARMv6-compatible processor [410fb767] revision 7 (ARMv7), cr=00c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
[    0.000000] Machine: BCM2708
[    0.000000] Memory policy: ECC disabled, Data cache writeback
[    0.000000] On node 0 totalpages: 114688
[    0.000000] free_area_init_node: node 0, pgdat c050db28, node_mem_map c05b6000
[    0.000000]   Normal zone: 896 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 113792 pages, LIFO batch:31
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 113792
[    0.000000] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1280 bcm2708_fb.fbheight=960 bcm2708.boardrev=0xf bcm2708.serial=0x496c5807 smsc95xx.macaddr=B8:27:EB:6C:58:07 sdhci-bcm2708.emmc_clock_freq=100000000 vc_mem.mem_base=0x1c000000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 448MB = 448MB total
[    0.000000] Memory: 448872k/448872k available, 9880k reserved, 0K highmem
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
[    0.000000]     vmalloc : 0xdc800000 - 0xe8000000   ( 184 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xdc000000   ( 448 MB)
[    0.000000]     modules : 0xbf000000 - 0xc0000000   (  16 MB)
[    0.000000]       .text : 0xc0008000 - 0xc04c0e78   (4836 kB)
[    0.000000]       .init : 0xc04c1000 - 0xc04e0b10   ( 127 kB)
[    0.000000]       .data : 0xc04e2000 - 0xc050e1c0   ( 177 kB)
[    0.000000]        .bss : 0xc050e1e4 - 0xc05b5128   ( 668 kB)
[    0.000000] NR_IRQS:330
[    0.000000] sched_clock: 32 bits at 1000kHz, resolution 1000ns, wraps every 4294967ms
[    0.000000] timer_set_mode: unhandled mode:1
[    0.000000] timer_set_mode: unhandled mode:3
[    0.000000] Console: colour dummy device 80x30
[    0.000000] console [tty1] enabled
[    0.000946] Calibrating delay loop... 697.95 BogoMIPS (lpj=3489792)
[    0.060146] pid_max: default: 32768 minimum: 301
[    0.060627] Mount-cache hash table entries: 512
[    0.061122] Initializing cgroup subsys cpuacct
[    0.061214] Initializing cgroup subsys devices
[    0.061250] Initializing cgroup subsys freezer
[    0.061282] Initializing cgroup subsys blkio
[    0.061425] CPU: Testing write buffer coherency: ok
[    0.061764] hw perfevents: enabled with v6 PMU driver, 3 counters available
[    0.062978] devtmpfs: initialized
[    0.073358] NET: Registered protocol family 16
[    0.074046] bcm2708.uart_clock = 0
[    0.075666] hw-breakpoint: found 6 breakpoint and 1 watchpoint registers.
[    0.075723] hw-breakpoint: maximum watchpoint size is 4 bytes.
[    0.075761] mailbox: Broadcom VideoCore Mailbox driver
[    0.075865] bcm2708_vcio: mailbox at f200b880
[    0.075970] bcm_power: Broadcom power driver
[    0.076008] bcm_power_open() -> 0
[    0.076033] bcm_power_request(0, 8)
[    0.576719] bcm_mailbox_read -> 00000080, 0
[    0.576761] bcm_power_request -> 0
[    0.576786] Serial: AMBA PL011 UART driver
[    0.576954] dev:f1: ttyAMA0 at MMIO 0x20201000 (irq = 83) is a PL011 rev3
[    0.886984] console [ttyAMA0] enabled
[    0.912500] bio: create slab <bio-0> at 0
[    0.917710] SCSI subsystem initialized
[    0.921709] usbcore: registered new interface driver usbfs
[    0.927437] usbcore: registered new interface driver hub
[    0.933023] usbcore: registered new device driver usb
[    0.939061] Switching to clocksource stc
[    0.943311] FS-Cache: Loaded
[    0.946495] CacheFiles: Loaded
[    0.963256] NET: Registered protocol family 2
[    0.968093] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.976268] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[    0.984315] TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
[    0.991271] TCP: Hash tables configured (established 16384 bind 16384)
[    0.997880] TCP reno registered
[    1.001054] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    1.006969] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    1.013786] NET: Registered protocol family 1
[    1.018926] RPC: Registered named UNIX socket transport module.
[    1.025062] RPC: Registered udp transport module.
[    1.029786] RPC: Registered tcp transport module.
[    1.034538] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    1.041283] bcm2708_dma: DMA manager at dc808000
[    1.046082] bcm2708_gpio: bcm2708_gpio_probe c04e9c18
[    1.051539] vc-mem: phys_addr:0x00000000 mem_base=0x1c000000 mem_size:0x20000000(512 MiB)
[    1.060837] audit: initializing netlink socket (disabled)
[    1.066388] type=2000 audit(0.750:1): initialized
[    1.182825] VFS: Disk quotas dquot_6.5.2
[    1.187072] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    1.194616] FS-Cache: Netfs 'nfs' registered for caching
[    1.200876] msgmni has been set to 876
[    1.206738] io scheduler noop registered
[    1.210708] io scheduler deadline registered (default)
[    1.216149] io scheduler cfq registered
[    1.253113] Console: switching to colour frame buffer device 160x60
[    1.276445] kgdb: Registered I/O driver kgdboc.
[    1.290863] brd: module loaded
[    1.299188] loop: module loaded
[    1.303337] vcos: [1]: vchiq_init_state: slot_zero = 0xffd80000, is_master = 0
[    1.310936] vcos: [1]: vchiq_init_state: called
[    1.316451] vcos: [1]: vchiq: initialised - version 2 (min 2), device 252.0
[    1.324392] usbcore: registered new interface driver smsc95xx
[    1.330360] cdc_ncm: 04-Aug-2011
[    1.333854] usbcore: registered new interface driver cdc_ncm
[    1.339666] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[    1.550736] Core Release: 2.80a
[    1.554099] Setting default values for core params
[    1.559050] Finished setting default values for core params
[    1.769914] Using Buffer DMA mode
[    1.773365] Periodic Transfer Interrupt Enhancement - disabled
[    1.779334] Multiprocessor Interrupt Enhancement - disabled
[    1.785070] OTG VER PARAM: 0, OTG VER FLAG: 0
[    1.789549] Dedicated Tx FIFOs mode
[    1.793379] dwc_otg: Microframe scheduler enabled
[    1.793426] dwc_otg bcm2708_usb: DWC OTG Controller
[    1.798491] dwc_otg bcm2708_usb: new USB bus registered, assigned bus number 1
[    1.806002] dwc_otg bcm2708_usb: irq 32, io mem 0x00000000
[    1.811695] Init: Port Power? op_state=1
[    1.815845] Init: Power Port (0)
[    1.819289] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.826311] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.839712] usb usb1: Product: DWC OTG Controller
[    1.850613] usb usb1: Manufacturer: Linux 3.2.27+ dwc_otg_hcd
[    1.862563] usb usb1: SerialNumber: bcm2708_usb
[    1.874119] hub 1-0:1.0: USB hub found
[    1.884056] hub 1-0:1.0: 1 port detected
[    1.894709] dwc_otg: FIQ enabled
[    1.894728] dwc_otg: NAK holdoff enabled
[    1.894751] Module dwc_common_port init
[    1.895098] usbcore: registered new interface driver uas
[    1.906463] Initializing USB Mass Storage driver...
[    1.917567] usbcore: registered new interface driver usb-storage
[    1.929547] USB Mass Storage support registered.
[    1.940379] usbcore: registered new interface driver libusual
[    1.952501] mousedev: PS/2 mouse device common for all mice
[    1.964925] bcm2835-cpufreq: min=700000 max=700000 cur=700000
[    1.970764] bcm2835-cpufreq: switching to governor powersave
[    1.982389] bcm2835-cpufreq: switching to governor powersave
[    1.994200] cpuidle: using governor ladder
[    2.010159] cpuidle: using governor menu
[    2.020189] sdhci: Secure Digital Host Controller Interface driver
[    2.032326] sdhci: Copyright(c) Pierre Ossman
[    2.042656] sdhci: Enable low-latency mode
[    2.052605] bcm_power_open() -> 1
[    2.061956] Registered led device: mmc0::
[    2.063428] mmc0: SDHCI controller on BCM2708_Arasan [platform] using platform's DMA
[    2.077246] mmc0: BCM2708 SDHC host at 0x20300000 DMA 2 IRQ 77
[    2.089095] sdhci-pltfm: SDHCI platform and OF driver helper
[    2.101928] Indeed it is in host mode hprt0 = 00021501
[    2.113349] Registered led device: led0
[    2.119124] usbcore: registered new interface driver usbhid
[    2.142743] usbhid: USB HID core driver
[    2.174277] TCP cubic registered
[    2.185075] Initializing XFRM netlink socket
[    2.200528] mmc0: problem reading SD Status register.
[    2.223123] NET: Registered protocol family 17
[    2.239098] Registering the dns_resolver key type
[    2.254394] mmc0: new high speed SDHC card at address aaaa
[    2.273179] VFP support v0.3: implementor 41 architecture 1 part 20 variant b rev 5
[    2.287655] mmcblk0: mmc0:aaaa SU08G 7.40 GiB
[    2.298995] registered taskstats version 1
[    2.310172] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[    2.322938]  mmcblk0: p1 p2
[    2.354302] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
[    2.368527] VFS: Mounted root (ext4 filesystem) on device 179:2.
[    2.389041] devtmpfs: mounted
[    2.398956] Freeing init memory: 124K
[    2.408740] usb 1-1: new high-speed USB device number 2 using dwc_otg
[    2.421924] Indeed it is in host mode hprt0 = 00001101
[    2.633788] usb 1-1: New USB device found, idVendor=0424, idProduct=9512
[    2.647140] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.661806] hub 1-1:1.0: USB hub found
[    2.672589] hub 1-1:1.0: 3 ports detected
[    2.963569] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[    3.083788] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[    3.109903] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.133545] smsc95xx v1.0.4
[    3.208733] smsc95xx 1-1.1:1.0: eth0: register 'smsc95xx' at usb-bcm2708_usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:6c:58:07
[    3.323343] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[    3.474859] usb 1-1.2: New USB device found, idVendor=0846, idProduct=9030
[    3.500104] usb 1-1.2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[    3.533174] usb 1-1.2: Product: WNA1100
[    3.548817] usb 1-1.2: Manufacturer: NETGEAR WNA
[    3.572360] usb 1-1.2: SerialNumber: 12345
[    3.683381] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
[    3.825123] usb 1-1.3: string descriptor 0 read error: -32
[    3.841188] usb 1-1.3: New USB device found, idVendor=03eb, idProduct=0902
[    3.854738] usb 1-1.3: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[    3.870867] hub 1-1.3:1.0: USB hub found
[    3.881604] hub 1-1.3:1.0: 4 ports detected
[    4.038197] udevd[137]: starting version 175
[    4.173482] usb 1-1.3.2: new full-speed USB device number 6 using dwc_otg
[    4.336550] usb 1-1.3.2: New USB device found, idVendor=046d, idProduct=c52e
[    4.382772] usb 1-1.3.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    4.398898] usb 1-1.3.2: Product: USB Receiver
[    4.410226] usb 1-1.3.2: Manufacturer: Logitech
[    4.442791] input: Logitech USB Receiver as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3.2/1-1.3.2:1.0/input/input0
[    4.498464] generic-usb 0003:046D:C52E.0001: input: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-bcm2708_usb-1.3.2/input0
[    4.552277] input: Logitech USB Receiver as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3.2/1-1.3.2:1.1/input/input1
[    4.583568] generic-usb 0003:046D:C52E.0002: input,hiddev0: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-bcm2708_usb-1.3.2/input1
[    7.078600] cfg80211: Calling CRDA to update world regulatory domain
[    8.025601] usb 1-1.2: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[    8.261277] ath9k_htc 1-1.2:1.0: ath9k_htc: HTC initialized with 33 credits
[    8.492551] ath9k_htc 1-1.2:1.0: ath9k_htc: FW Version: 1.3
[    8.505945] ath: EEPROM regdomain: 0x60
[    8.505967] ath: EEPROM indicates we should expect a direct regpair map
[    8.506001] ath: Country alpha2 being used: 00
[    8.506012] ath: Regpair used: 0x60
[    8.539828] ieee80211 phy0: Atheros AR9271 Rev:1
[    8.554521] Registered led device: ath9k_htc-phy0
[    8.554556] usb 1-1.2: ath9k_htc: USB layer initialized
[    8.571317] usbcore: registered new interface driver ath9k_htc
[   12.175286] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[   12.666760] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[   13.499995] bcm2835 ALSA card created!
[   13.524013] bcm2835 ALSA chip created!
[   13.548348] bcm2835 ALSA chip created!
[   13.569997] bcm2835 ALSA chip created!
[   13.586161] bcm2835 ALSA chip created!
[   13.599910] bcm2835 ALSA chip created!
[   13.613618] bcm2835 ALSA chip created!
[   13.627068] bcm2835 ALSA chip created!
[   22.710641] smsc95xx 1-1.1:1.0: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   27.054842] Adding 102396k swap on /var/swap.  Priority:-1 extents:1 across:102396k SS

Failed to initiate AP Scan

Network config

Scanning

Update Feb 22

I couldn't make it to work even with external powered USB hub. Same "Failed to initiate AP Scan" but "Scan" functionality works. Issue is only with connecting to a access point.

My usb wifi adapter

Update Aug'13 2013

Three words NOOBS is awesome. The recent version of Raspbian installed with NOOBS is working out of the box without any additional steps.

Not sure it is the version comes with NOOBS v.1.2 package, I have tried apt-get upgrade to update my installed version of Raspbian and was not successful.

Note: Still It doesn't work with hidden SSID.

share|improve this question
1  
It looks pretty good up to the connecting part. It would be nice to see some real messages. You might look at (tail -f) /var/log/auth.log and daemon.log (other logfiles, too) and see if anything interesting pops up there while you try to connect to your network. –  XTL Jan 28 '13 at 7:44
    
Are the settings in /etc/wpa_supplicant/wpa_supplicant.conf correct? Maybe this helps –  Frederic Jan 28 '13 at 12:05
    
What kind of wifi network do you have? –  TheDoctor Jul 31 '13 at 15:27
    
Netgear WGR614v7 router configured with WPA2 personal –  palaniraja Aug 1 '13 at 6:47
add comment

2 Answers 2

I got my Netgear N150 working by adding ap_scan=0 to /etc/wpa_supplicant/wpa_supplicant.conf

share|improve this answer
add comment

Your dmesg says that you're using a WNA1100 dongle. Try this post: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=26&t=21569

share|improve this answer
    
yep I tried it without any luck. I have also tried the ap_scan=0 which dyret mentioned in another answer. –  palaniraja Jul 31 '13 at 6:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.