Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

When I log in on ssh to my Raspberry Pi in the same network, everything works perfectly. But when I log in over the internet I get a weird welcome message http://puu.sh/1UOUN and I cant type any commands. Also vnc refuses the connection actively over the internet, but works fine to in the local network.

Help is much appreciated.

share|improve this question
    
Did you try reset and ctl-L? Maybe you just don't see what you are typing. –  M Noit Jan 30 '13 at 11:31
    
i can type in it and see it, but its not send, it comes up with things like ^[[A if you press the arrow keys, and it responds to nothing –  Tom Jan 30 '13 at 11:49
    
It could be a problem with your router configuration. How is the RPi connected to the internet? Can you access other machines on the network from the internet? –  Craig Jan 31 '13 at 1:59
1  
please correct your SSH client configuration. Linux sends LF as line ending not CR+LF. VNC uses a separate TCP connection for data transfer. When accessing from the Internet you need to tunnel this connection through you SSH tunnel (See putty configuration) –  Lars Pötter Feb 1 '13 at 16:07
add comment

2 Answers

Try typing stty sane, which makes your tty port settings "sane".

The output looks like what you see when you dump a Linux file on Windows. Are you using a different ssh client or client configuration on the inside vs outside networks?

You might also have some other program attached to that tty port. If you are able to type, try ps -ft `tty` and see if anything unexpected appears.

share|improve this answer
    
I think @Lars may have nailed it, above. –  Jim L. Jul 19 '13 at 21:55
add comment

Have you checked your translation/keyboard settings? At one point I was using a really odd computer to login to my home server over ssh and had to play with the Terminal > Keyboard settings in putty. Also, make sure that under Window > Translation the computer you're using has UTF-8 set.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.