Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

There are many posts here about people trying to set a custom resolution but they all have similar answers;

Uncomment and set the following two values to your preference;
hdmi_group=2
hdmi_mode=39

So in my case I want 1360x768 which is value 39 above.

My problem is that I have tried all different values listed at http://elinux.org/RPi_config.txt. Also with hdmi_group=1. It never works. Everytime I reboot my Pi or Pi and TV, it always starts up in 720P which doesn't fit the screen properly. I want 1360x768.

I have also tried setting hdmi_safe=1, whilst this squashed the picture a bit, it didn't really help.

share|improve this question

2 Answers 2

If your problem is cutting the edge of the screen, i think you should use the overscan options.

  • overscan_left :: number of pixels to skip on left
  • overscan_right :: number of pixels to skip on right
  • overscan_top :: number of pixels to skip on top
  • overscan_bottom :: number of pixels to skip on bottom

You can put this into the config.txt.

share|improve this answer
up vote 1 down vote accepted

So it seems that the TV was actually the problem. After several reboots of both the Pi and TV (I removed all static settings regarding resolution and HDMI group etc), a change of HDMI cable, and port on the TV; It's fixed now.

So other readers be warned; Cheap TV's used as displays not for watching media, are cheap for a reason (In my case, it seems to ignore the HDMI settings being offered by the Pi at start up!).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.