Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had an installation with motion running as webcam-server. I reinstalled the linux-distro and reinstalled motion, and now "root" has no access to the webcam. The "pi" user still can access and work with the webcam, but the "pi" user only. Is there a way to change rights for connected webcams? I have already reinstalled motion, and that didn't help!

share|improve this question
Is the webcam off when root tries to access it? Or is some process being run by pi capturing a stream? – Lord Loh. Feb 21 '13 at 18:58
Well, when running motion under "pi" the "activity LED" of the webcam is active. When i try to access the webcam with motion under "root" the LED doesn't turn on.. so i guess that motion cannot connect to the device.. and when trying to let it run as root there's no other process that try to access the webcam too. (webcam: eyetoy > already worked 1 month ago before reinstalling the distro) >> *running with "SUDO" doesnt work, also which "real root (root)" it doesnt.. – Floler Feb 21 '13 at 19:04
Can you find out what device is being used for the webcam in the /dev/ directory? Does that device file have the required permissions? Look for the permission of the original device file and not any symlink that it may have. – Lord Loh. Feb 21 '13 at 23:17
what distro are you using? – Eineki Mar 24 '13 at 15:38

Does your root user has a password set? If not, I'd set it a password and try again.

sudo passwd root
share|improve this answer
root and pi are both password protected.. this was one of the first things i did right after installing the linux distro – Floler Feb 21 '13 at 18:46
Was root added to the proper groups? Maybe there is an issue with the device not having been put in the proper scope. – Jacobm001 Jul 22 '13 at 18:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.