Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I have heard that there are several MONO issues with the current version of Raspbian Wheezy.

What is the extent of these issues? Are they minor or do they severely stifle programming? Other people have effectively demonstrated this issue.

Also, can someone please provide links with other known issues in our current MONO distribution?

share|improve this question

closed as not constructive by scruss, Mark Booth, Impulss, bearbin, xxmbabanexx Apr 14 '13 at 18:56

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you please add some more details? –  xxmbabanexx Apr 14 '13 at 18:56
    
@xxmbabanexx why was this question closed? I got a clear answer which I have marked as correct too? There ARE issues with MONO and as I dont know exactly what other problems there might be, I would like peoples answers on their experiences with MONO and the current amount of bugs. This seems quite usefull to most people looking into using MONO on the PI ? What do you want me to at as details? I will be happy to add more, I just tried to keep it short and rsgoheen understood me quite well ? –  BerggreenDK Apr 15 '13 at 10:08
add comment

1 Answer 1

up vote 4 down vote accepted

I would consider this to be pretty significant. It's due to Mono's lack of support for hardfp, and it affects more than just DateTime.

Here's the bug as it's being tracked by the Mono project: Bug 7938 - mono doesn't work on hard float abi on ARM. If you look at the bottom of that page, you'll see that there are two other bugs that have been determined to have the same root cause of this one. Those other issues are for Math.Pow() and casting from uint, which shows that this is a pretty low level bug affecting large parts of the framework.

That said, whether or not it is significant for your project is something you're going to have to determine on your own. If your project has lots of code that relies on DateTime.Now.ToString(), then that's a pretty big impact. However, DateTime.Now.Year and similar calls do return the correct values. I'm just getting started with a Pi and Mono, so I'm not sure how much this will impact anything I'm thinking about porting over from Windows.

The immediate workaround would be to use the softfp version of Debian Wheezy. Or to wait for a fix or patch. There is a mention of a patch in the ticket, but I'm not sure if this fully fixes the problem or the process of actually applying this patch to your own instance of Mono.

share|improve this answer
    
dang, I cant get the softfp image to run. I just get the PI logo and a blinking cursor. have tried 3 times now, with different mirrors. but the hardfp runs smoothly, even as a fresh install on the same card. –  BerggreenDK Feb 25 '13 at 21:33
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.