Take the 2-minute tour ×
Raspberry Pi Stack Exchange is a question and answer site for users and developers of hardware and software for Raspberry Pi. It's 100% free, no registration required.

I've just started my Raspberry Pi for the first time (Model B Revision 1.0, Raspbian on a card from RS).

At no stage was I presented with the Raspi-config menu. I've tried to access it using the sudo raspi-config command, but I get the message "command not found".

I've also tried updating the OS using apt-get update and apt-get upgrade but get messages containing "failed to fetch...".

Is there any way of updating my OS using the existing image I have on the SD card from RS, or do I need to get a brand new image and start again using a fresh SD card?

share|improve this question
add comment

2 Answers 2

It sounds like the cards RS is shipping don't have raspi-config installed. You can install it from the repository using sudo apt-get install raspi-config (you may have to run sudo apt-get update first. The package is in the http://archive.raspberrypi.org/debian/ repository.

As for the "failed to fetch..." error message when running sudo apt-get update, this is a networking issue, as the Pi isn't able to connect to the repository.

If you can get networking working, you can grab the script and any OS updates without wiping the card and writing a new image.

share|improve this answer
add comment

Can you see it when you pop your SD card into a card reader in windows?

I had a similar problem with mine and i couldn't even see the 56MB partition in windows so I just downloaded the latest OS and reflashed as per the instructions on the Pi website. After that the config file was there in windows and showed on first boot on the Pi

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.