apt-get is a shell command on the Debian Linux distribution for installing and updating various different packages.

learn more… | top users | synonyms

1
vote
2answers
39 views

How do I fix this 'transmission-daemon: command not found' error?

I set up a brand new Raspbmc and installed transmission-daemon on it. I was able to stop it by issuing a sudo /etc/init.d/transmission-daemon stop, after which I proceed to make some changes to ...
0
votes
0answers
18 views

How to upgrade to exfat-fuse 1.1.0-2

I have tried $ sudo apt-get install exfat-fuse=1.1.0-2 Reading package lists... Done Building dependency tree Reading state information... Done E: Version '1.1.0-2' for 'exfat-fuse' was not ...
0
votes
0answers
14 views

Problem with debconf when trying to upgrade

I have problem with upgrade my system. When i used command: sudo apt-get upgrade I get an error: Use of uninitialized value in concatenation (.) or string at ...
0
votes
1answer
30 views

install Raspbian packages directly from Ubuntu with chroot to Raspbian file system (on SD card)

I'm connecting to internet with my pc using Ethernet cable, I just have one internet cable input and one RJ45 cable, so I cant share internet with my Raspberry. is there any solution to install ...
0
votes
1answer
32 views

Cannot find a LSB script for mopidy

I'm trying to install mopidy on my Pi running raspbmc but it complains about missing LSB script: $ sudo apt-get install mopidy Reading package lists... Done Building dependency tree Reading state ...
2
votes
1answer
72 views

proper apt-get configuration for epiphany browser

I have been using the epiphany browser beta for a while, having installed it using these instructions. Now that the browser is part of the raspbian distribution, should I continue to include ...
0
votes
0answers
86 views

how to install libtbb-dev in raspberry-pi

I am trying to install libtbb-dev on my raspberry-pi as part of installing opencv. sudo apt-get install libtbb-dev But i am getting an error as Package libtbb-dev is not available,but is refered ...
0
votes
1answer
43 views

how do I install the djpeg binary? [closed]

I have a suite of scripts which I require and which make extensive use of djpeg. but 'which djpeg' returns nothing. How do I get the djpeg binary installed on my raspberry?
1
vote
1answer
125 views

apt-get update/upgrade fails on fresh image

I've created a fresh SD card with the weezy 2014-6-20 image. And follow these instructions to update. So after the freshly created image boots, I issue: sudo apt-get update sudo apt-get ...
0
votes
1answer
236 views

How do I keep my system up to date with Raspbmc?

Occasionally, my Raspbmc upgrades itself, downloading and installing new kernels and xbmc. How would I keep the other packages up-to-date? I'm not sure if it's recommended, but I tried sudo apt-get ...
0
votes
0answers
58 views

apt-get can't find packages

I've tried sudo apt-get install htop as per here. It doesn't return results: E: Unable to locate package python-software-properties. I've tried sudo apt-get update! Why doesn't this work?
0
votes
0answers
513 views

Official MongoDB Repo for ARM Processor

Is there an official MongoDB repo for the Raspberry Pi Following: http://docs.mongodb.org/manual/tutorial/install-mongodb-on-debian/ Got this issue: W: Failed to fetch ...
0
votes
1answer
259 views

Why can't I remove Apache?

I installed a LAMP stack with the following commands: $sudo apt-get install apache2 php5 libapache2-mod-php5 $sudo service apache2 restart $sudo apt-get install mysql-server mysql-client php5-mysql ...
0
votes
1answer
167 views

Unmet dependencies

While I was following a Raspberry Pi VLC hardware acceleration tutorial in the compiling stage I have received this error: configure: error: Package 'libavcodec' requires 'libavutil = 53.3.0' but ...
3
votes
1answer
154 views

Why are the Raspian repositories so out of date?

I'm trying to install Owncloud, which is currently at version 6.0.3. However, Raspian's version is from about two years ago. $ apt-cache show owncloud Package: owncloud Version: 4.0.4debian2-3.3 ...
0
votes
0answers
35 views

deluge breaks, can i downgrade libssl1.0.0?

It seems that the update for heartbleed (OpenSSL and libssl1.0.0) caused deluge's web Gui to break. Basically it doesn't load or for many people either doesn't load or crashes (for me I can web in ...
0
votes
1answer
85 views

Apt-get without net?

Many webpages have all kinds of instructions to do cool things and these instructions needs to do "apt-get...", but what if this Raspberry is not online? Is there any way to install/update apps ...
1
vote
1answer
1k views

Installing Python 3.4 on Raspberry Pi

Is it possible to run python 3.4 on a Raspberry Pi? Currently I have python 3.2, but the odd thing is that running sudo apt-get update sudo apt-get install python3 results in my Raspberry Pi ...
0
votes
1answer
267 views

apt-get “cannot locate the package”

I was following a tutorial online so I can install a USB DisplayLink monitor, and it told me to type: sudo apt-get install git-core gcc-4.6-arm-linux-gnueabi I tried that, and it says it ...
1
vote
2answers
119 views

Debian Release Upgrade

I am wondering how I do a Debian Release upgrade on my Pi? I know I can do an apt-get dist-upgrade but this is not a release upgrade. The debian tool do-release-upgrade does not exist on my Pi's ...
0
votes
1answer
276 views

Installing software with dependencies

I want to install the last version of Minimodem on my Raspi. If I do: sudo apt-get install minimodem I obtain the version 0.8.1, which is not the last one that the author has released. The last ...
2
votes
2answers
1k views

apt-get upgrade fails because of some dependency loop

If I update my Raspberry PI with: sudo apt-get upgrade I run into follwoing dependency errors: lighttpd (1.4.31-4+deb7u3) wird eingerichtet ... insserv: warning: script 'mathkernel' missing LSB ...
0
votes
1answer
141 views

bash can't find Rails in GUI

I am trying to get Ruby on Rails set up on my laptop. I ran through the guide here: http://elinux.org/RPi_Ruby_on_Rails Everything seemed fine, but when I went to run a Rails server while using ...
1
vote
1answer
301 views

How do I install the piFace Control & Display

I bought one of these (PiFace Control & Display) and according to the online instructions here, it says to run: apt-get install python3-pifacecad but when I do that I get: Reading package ...
1
vote
3answers
146 views

DrRacket seg fault

I'm trying to install racket on my RaspBerry Pi. I've installed racket via sudo apt-get install racket When I enter 'racket', it runs just fine. But when I run 'drracket' or 'sudo drracket', it ...
0
votes
1answer
299 views

How long should dist-upgrade take?

I have a fresh raspbian image on a class-10 32gb SDHC card in my Raspberry Pi Model B, created according to instructions on the raspberry pi website. My actual internet download speed is >10 mbytes/s. ...
0
votes
1answer
462 views

Hash sum mismatch error

Context: I have 8 Raspberry Pi Computers in my class. After flashing the most recent version of Raspbian onto 8GB SD cards which were originally sold with NOOBS on them (the cards are therefore ...
1
vote
1answer
575 views

Raspbian apt-get dependency error with Python?

I've ran the following command on Raspbian: $ sudo apt-get upgrade But now when I try to do: $ sudo apt-get install -f or any other apt-get command, I got this error and I can't get rid of it: ...
2
votes
3answers
1k views

“Encountered a section with no Package: header” error?

I am running a bunch of class Raspberry Pi computers behind a school proxy. I'm using Raspbian off a very recent NOOBS image. The internet connection is supplied through the school WiFi and after ...
0
votes
1answer
34 views

Building a “configuration package”

I recently got a raspberry pi which I intend to use for some photography timelapsing/post processing while I'm on the road... I've gotten the system setup now (albeit with some hassle) but I'd like ...
2
votes
1answer
211 views

Install XFCE after installing Raspbian without internet connection?

I have a Raspberry Pi Model B with a 16GB PNY class 4 SD card for memory that I received two days ago. I'm running Raspbian on NOOBS. After spending some time with it and interchanging operating ...
4
votes
2answers
2k views

Why APT can't locate GNURADIO package even though it apparently exists in repository?

I have been trying to install the GNURADIO package that is listed on the raspbian mirror: http://archive.raspbian.org/raspbian/pool/main/g/gnuradio/ I've added the repo to my sources.list as below: ...
3
votes
1answer
384 views

Why does apt-get dist-upgrade want to remove upstart again?

I usually do apt-get dist-upgrade instead of a mere apt-get upgrade for consistency reasons. However, for the first time on one of my RaspberryPis I got the following: # apt-get dist-upgrade Reading ...
1
vote
0answers
506 views

Can anybody connect to mirrordirector.raspbian.org?

I keep trying apt-get update, but it gives me 504 errors for mirrordirector.raspbian.org I have tried wget mirrordirector.raspbian.org and it gives me the following output: If anybody can ...
3
votes
4answers
2k views

apt-get update gives me errors with mirrordirector.raspbian.org

I am trying to install tightvncserver on my rPi model A running Raspbian. I am connecting to the rPi via SSH from my laptop. I can connect to the internet, but cant install the package. It seems to be ...
1
vote
1answer
460 views

Can't install apache

I can't download apache2 and php5: sudo apt-get install apache2 php5 libapache2-mod-php5 Gives me the error "Failed to fetch [URL] 404 Not Found". The raspberry is connected via ethernet to my ...
4
votes
2answers
3k views

Changing to XFCE from LXDE

Apologies if this seems straight forward but I've recently downloaded XFCE to replace LXDE environment. I did this by using sudo apt-get install xfce4 and following all the instructions. Then to ...
1
vote
1answer
553 views

Unable to install likewise-open in Raspberry Pi

I've tried to install likewise-open in my Raspberry Pi. Before that, I've edited my repository list, where /etc/apt/sources.list is as follows: deb http://mirrordirector.raspbian.org/raspbian/ wheezy ...
1
vote
0answers
996 views

Installing isc-dhcp-server error

I am following this [1] tutorial, and trying to install sudo apt-get install hostapd isc-dhcp-server according to this [2] step. I am getting the following error: [FAIL] Starting ISC DHCP ...
4
votes
4answers
15k views

apt-get installation doesn't work on raspberry pi

I tried to install python-pip by typing this command: sudo apt-get install python-pip and the result is this below: Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main python2.6-minimal ...
2
votes
2answers
2k views

held broken packages

When I try and do sudo apt-get update it seems to me that I have 4 newer packages than what is to be installed. Any help would be appreciated. Thank you. Module Index Update Packages Building ...
0
votes
1answer
420 views

my raspberry wont let me upgrade

Every time I try to upgrade I receive the following ouptu: sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run ...
3
votes
5answers
17k views

isc-dhcp-server install and run problem

Im trying to set up my pi as an access point with the instructions from Adafruit. However, for some reason, sudo apt-get install isc-dhcp-server always fails. I have looked at this link, but there is ...
0
votes
0answers
223 views

Discourse on a raspberry pi

I'm trying to install on my raspberry pi using the installation instruction for ubuntu: Install Discourse on Ubuntu. It went quite well until bundle install --deployment and now I'm having a hard ...
0
votes
2answers
193 views

Apt-get fails because of libqtcore and libqtdbus4

On a fresh-today Raspbian build I did an apt-get update followed by an apt-get ugrade. I got the following error message: sal@raspberrypi:~$ sudo apt-get upgrade Reading package lists... Done ...
2
votes
1answer
746 views

How to install pre-compiled Ruby 2.0 on Raspbian?

I am usually recommend to people who want to install Ruby to use something like RVM or rbenv (my preference). However, I'm in the process of installing Ruby from source (using rbenv) and it has taken ...
8
votes
3answers
20k views

Raspberry Pi apt-get update/upgrade on Raspbian hangs?

Whenever I try to update my pi using sudo apt-get update && sudo apt-get upgrade it will often hang at some point during the installation. It's been different ones each time, but the last was ...
7
votes
1answer
2k views

What is the difference between rpi-update and sudo-apt upgrade?

I'm wondering what the difference is between running the git-hub obtained program rpi-update and using sudo apt-get update followed by sudo apt-get upgrade. I've checked around and cannot find the ...
1
vote
0answers
279 views

Raspberry Pi using up my bandwidth?

Whenever I use something like apt-get git clone on my Pi (using Wifi connection via dongle), the internet for all other devices connected to the router drops considerably, to the point where some ...
5
votes
2answers
2k views

How does apt-get work?

Normally, when I want to download something on my pi (for instance this vnc app, I use apt-get <insert app>? But, sometimes an app is not in the apt-get area (not sure what proper name is) and ...