4 replaced http://superuser.com/ with https://superuser.com/
source | link

It could be that your Pi is trying to do a reverse DNS lookup of the client's connecting hostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things, of course don't forget to reload and you are good to go!

service ssh reload

And you should have a near instant SSH

You can also try SSH-ing with the -v verbose option to provide output to the client that may help in diagnosing where the timeouts are occuring.

This behaviour isn't unique to the Raspberry Pi nor Raspbian also see SuperUser: Top causes of slow ssh loginsSuperUser: Top causes of slow ssh logins where UseDNS no is the common solution.

It could be that your Pi is trying to do a reverse DNS lookup of the client's connecting hostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things, of course don't forget to reload and you are good to go!

service ssh reload

And you should have a near instant SSH

You can also try SSH-ing with the -v verbose option to provide output to the client that may help in diagnosing where the timeouts are occuring.

This behaviour isn't unique to the Raspberry Pi nor Raspbian also see SuperUser: Top causes of slow ssh logins where UseDNS no is the common solution.

It could be that your Pi is trying to do a reverse DNS lookup of the client's connecting hostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things, of course don't forget to reload and you are good to go!

service ssh reload

And you should have a near instant SSH

You can also try SSH-ing with the -v verbose option to provide output to the client that may help in diagnosing where the timeouts are occuring.

This behaviour isn't unique to the Raspberry Pi nor Raspbian also see SuperUser: Top causes of slow ssh logins where UseDNS no is the common solution.

3 link to manpages for -v option, service ssh reload, some small formatting and neater link to given SuperUser page
source | link

It could be that your Pi is trying to do a reverse DNS lookup of the client's connecting hostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things., of course don't forget to reload and you are good to go!

service ssh reload

And you should have a near instant SSH

You can also try sshSSH-ing with the -vvv parameter-v verbose option to provide output to the client that may help in diagnosing where the timeouts are occuring.

for other tipsThis behaviour isn't unique to try, have a look at this page on superuser.com the Raspberry Pi nor Raspbian also see httpSuperUser://superuser.com/questions/166359/top-causes-of-slow-ssh-logins Top causes of slow ssh logins where UseDNS no is the common solution.

It could be that your Pi is trying to do a reverse DNS lookup of the client's connecting hostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things.

You can also try ssh-ing with the -vvv parameter to provide output to the client that may help in diagnosing where the timeouts are occuring.

for other tips to try, have a look at this page on superuser.com http://superuser.com/questions/166359/top-causes-of-slow-ssh-logins

It could be that your Pi is trying to do a reverse DNS lookup of the client's connecting hostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things, of course don't forget to reload and you are good to go!

service ssh reload

And you should have a near instant SSH

You can also try SSH-ing with the -v verbose option to provide output to the client that may help in diagnosing where the timeouts are occuring.

This behaviour isn't unique to the Raspberry Pi nor Raspbian also see SuperUser: Top causes of slow ssh logins where UseDNS no is the common solution.

2 included more detail and a further debugging solution
source | link

It could be that your Pi is trying to do a reverse DNS lookup the hostname (via dns) of yourthe client's connecting ssh clienthostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things.

You can also try ssh-ing with the -vvv parameter to provide output to the client that may help in diagnosing where the timeouts are occuring.

for other tips to try, have a look at this page on superuser.com http://superuser.com/questions/166359/top-causes-of-slow-ssh-logins

It could be that your Pi is trying to lookup the hostname (via dns) of your connecting ssh client.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things.

for other tips to try, have a look at this page on superuser.com http://superuser.com/questions/166359/top-causes-of-slow-ssh-logins

It could be that your Pi is trying to do a reverse DNS lookup of the client's connecting hostname for security reasons, which is okay, but leads to the timeouts if you don't have a working reverse DNS.

when you do finally login, try adding

UseDNS no

to your /etc/ssh/sshd_config file, and see if that helps improve things.

You can also try ssh-ing with the -vvv parameter to provide output to the client that may help in diagnosing where the timeouts are occuring.

for other tips to try, have a look at this page on superuser.com http://superuser.com/questions/166359/top-causes-of-slow-ssh-logins

1
source | link