2 added 82 characters in body
source | link

Finally I've made it! The procedure was almost correct. I was just missing a few little details.

First, the timings: putting /usr/lib/vino/vino-server directly in lightdm autostart launched it before the X session was completely set-up. So I wrapped it into a script with a little bit of delay before the command:

#!/bin/bash

sleep 5
/usr/lib/vino/vino-server &

In turn, this script was called by a vino-server.desktop launcher, placed into /etc/xdg/autostart/ directory.

Second, permissions: the lightdm config file /etc/lightdm/lightdm.conf was enabling autologin for user pi:

#> grep ^autologin /etc/lightdm/lightdm.conf

autologin-user=pi

But I already created my own user and the wrapper script was in my home folder, andso some weird permission issue was preventing its execution. I changed the autologin-user setting in /etc/lightdm/lightdm.conf to my user, and now everything works fine and. Finally I can access my :0 display through VNC right after boot.

Finally I've made it! The procedure was almost correct. I was just missing a few little details.

First, the timings: putting /usr/lib/vino/vino-server directly in lightdm autostart launched it before the X session was completely set-up. So I wrapped it into a script with a little bit of delay before the command:

#!/bin/bash

sleep 5
/usr/lib/vino/vino-server &

In turn, this script was called by a vino-server.desktop launcher placed into /etc/xdg/autostart/

Second, the lightdm config file /etc/lightdm/lightdm.conf was enabling autologin for user pi:

#> grep ^autologin /etc/lightdm/lightdm.conf

autologin-user=pi

But the wrapper script was in my home, and some weird permission issue was preventing its execution. I changed the autologin-user setting in /etc/lightdm/lightdm.conf and now everything works fine and I can access my :0 display through VNC right after boot.

Finally I've made it! The procedure was almost correct. I was just missing a few little details.

First, the timings: putting /usr/lib/vino/vino-server directly in lightdm autostart launched it before the X session was completely set-up. So I wrapped it into a script with a little bit of delay before the command:

#!/bin/bash

sleep 5
/usr/lib/vino/vino-server &

In turn, this script was called by a vino-server.desktop launcher, placed into /etc/xdg/autostart/ directory.

Second, permissions: the lightdm config file /etc/lightdm/lightdm.conf was enabling autologin for user pi:

#> grep ^autologin /etc/lightdm/lightdm.conf

autologin-user=pi

But I already created my own user and the wrapper script was in my home folder, so some weird permission issue was preventing its execution. I changed the autologin-user setting in /etc/lightdm/lightdm.conf to my user, and now everything works fine. Finally I can access my :0 display through VNC right after boot.

1
source | link

Finally I've made it! The procedure was almost correct. I was just missing a few little details.

First, the timings: putting /usr/lib/vino/vino-server directly in lightdm autostart launched it before the X session was completely set-up. So I wrapped it into a script with a little bit of delay before the command:

#!/bin/bash

sleep 5
/usr/lib/vino/vino-server &

In turn, this script was called by a vino-server.desktop launcher placed into /etc/xdg/autostart/

Second, the lightdm config file /etc/lightdm/lightdm.conf was enabling autologin for user pi:

#> grep ^autologin /etc/lightdm/lightdm.conf

autologin-user=pi

But the wrapper script was in my home, and some weird permission issue was preventing its execution. I changed the autologin-user setting in /etc/lightdm/lightdm.conf and now everything works fine and I can access my :0 display through VNC right after boot.