Post Undeleted by Shreyas Murali
added 129 characters in body; deleted 15 characters in body
Source Link
Shreyas Murali
  • 2.4k
  • 1
  • 13
  • 20

Looks like you might be missing the python-smbus package.I2C has been disabled by the device tree overlay

Try installing this like soSee this discussion which appears to be the same as your code.

you can enable the I2C device using the sudo apt-get install pythonraspi-smbusconfig tool.

Looks like you might be missing the python-smbus package.

Try installing this like so

sudo apt-get install python-smbus

Looks like the I2C has been disabled by the device tree overlay

See this discussion which appears to be the same as your code.

you can enable the I2C device using the raspi-config tool.

Post Deleted by Shreyas Murali
Source Link
Shreyas Murali
  • 2.4k
  • 1
  • 13
  • 20

Looks like you might be missing the python-smbus package.

Try installing this like so

sudo apt-get install python-smbus