Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
6 added 1344 characters in body
source | link

However, whenWhen i set iptables rules onrun traceroute, it shows that packets are first sent to the R-Pi before it goes to block a specific sitemy ISP route which is of course expected.

Tracing route to one.one.one.one [1.1.1.1]
over a maximum of 30 hops:

1     1 ms     1 ms     1 ms  192.168.42.1
2     1 ms     1 ms     1 ms  192.168.0.1

For instance, i tried blocking 31.13.86.36 (facebook.com) on all the request will still go through withoutiptables chains, but nothing is being blocked. WhatI can i do to make the iptables rules take effectstill ping/browse from client machines. Here is what my iptables look like

Chain INPUT (policy ACCEPT 1355 packets, 104K bytes)
num   pkts bytes target     prot opt in     out     source               destination
1        0     0 DROP       all  --  *      *       31.13.86.36          0.0.0.0/0

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
num   pkts bytes target     prot opt in     out     source               destination
1     5352 5413K ACCEPT     all  --  eth0   wlan0   0.0.0.0/0            0.0.0.0/0            state RELATED,ESTABLISHED
2     3346  650K ACCEPT     all  --  wlan0  eth0    0.0.0.0/0            0.0.0.0/0
3        0     0 DROP       all  --  *      *       31.13.86.36          0.0.0.0/0
4        0     0 DROP       all  --  *      *       0.0.0.0/0            31.13.86.36

Chain OUTPUT (policy ACCEPT 1013 packets, 139K bytes)
num   pkts bytes target     prot opt in     out     source               destination
1        0     0 DROP       all  --  *      *       0.0.0.0/0           31.13.86.36

However, when i set iptables rules on the R-Pi to block a specific site, the request will still go through without being blocked. What can i do to make the iptables rules take effect.

When i run traceroute, it shows that packets are first sent to the R-Pi before it goes to my ISP route which is of course expected.

Tracing route to one.one.one.one [1.1.1.1]
over a maximum of 30 hops:

1     1 ms     1 ms     1 ms  192.168.42.1
2     1 ms     1 ms     1 ms  192.168.0.1

For instance, i tried blocking 31.13.86.36 (facebook.com) on all the iptables chains, but nothing is being blocked. I can still ping/browse from client machines. Here is what my iptables look like

Chain INPUT (policy ACCEPT 1355 packets, 104K bytes)
num   pkts bytes target     prot opt in     out     source               destination
1        0     0 DROP       all  --  *      *       31.13.86.36          0.0.0.0/0

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
num   pkts bytes target     prot opt in     out     source               destination
1     5352 5413K ACCEPT     all  --  eth0   wlan0   0.0.0.0/0            0.0.0.0/0            state RELATED,ESTABLISHED
2     3346  650K ACCEPT     all  --  wlan0  eth0    0.0.0.0/0            0.0.0.0/0
3        0     0 DROP       all  --  *      *       31.13.86.36          0.0.0.0/0
4        0     0 DROP       all  --  *      *       0.0.0.0/0            31.13.86.36

Chain OUTPUT (policy ACCEPT 1013 packets, 139K bytes)
num   pkts bytes target     prot opt in     out     source               destination
1        0     0 DROP       all  --  *      *       0.0.0.0/0           31.13.86.36
5 added 233 characters in body
source | link

I am working on a network security project that can inspect network traffic before forwarding and accepting traffic from the internet.

I have a R-Pi B+ Model running raspbian stretch lite where the in-built NIC is connected to my ISP router and i also have a wireless USB adapter to create a wireless network where clients can connect to. (Used hostapd and isc-dhcp-server for this). I used this tutorial to set up the R-Pi as a wireless AP https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point?view=all

Here is what my set up looks like:

Smartphone(192.168.42.10) ---> wlan0(192.168.42.1) ---> R-Pi---> eth0(192.168.0.17) ---> ISP Router(192.168.0.1) ---> Internet

Smartphone(192.168.42.10) ---> wlan0(192.168.42.1) ---> R-Pi---> eth0(192.168.0.17) ---> ISP Router(192.168.0.1) ---> InternetMy ip route command looks like this:

default via 192.168.0.1 dev eth0
192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.17
192.168.42.0/24 dev wlan0 proto kernel scope link src 192.168.42.1

However, when i set iptables rules on the R-Pi to block a specific site, the request will still go through without being blocked. Is there anythingWhat can i am missing here?do to make the iptables rules take effect.

I am working on a network security project that can inspect network traffic before forwarding and accepting traffic from the internet.

I have a R-Pi B+ Model running raspbian stretch lite where the in-built NIC is connected to my ISP router and i also have a wireless USB adapter to create a wireless network where clients can connect to. (Used hostapd and isc-dhcp-server for this). I used this tutorial to set up the R-Pi as a wireless AP https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point?view=all

Here is what my set up looks like:

Smartphone(192.168.42.10) ---> wlan0(192.168.42.1) ---> R-Pi---> eth0(192.168.0.17) ---> ISP Router(192.168.0.1) ---> Internet

However, when i set iptables rules on the R-Pi to block a specific site, the request will still go through without being blocked. Is there anything i am missing here?

I am working on a network security project that can inspect network traffic before forwarding and accepting traffic from the internet.

I have a R-Pi B+ Model running raspbian stretch lite where the in-built NIC is connected to my ISP router and i also have a wireless USB adapter to create a wireless network where clients can connect to. (Used hostapd and isc-dhcp-server for this). I used this tutorial to set up the R-Pi as a wireless AP https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point?view=all

Here is what my set up looks like:

Smartphone(192.168.42.10) ---> wlan0(192.168.42.1) ---> R-Pi---> eth0(192.168.0.17) ---> ISP Router(192.168.0.1) ---> Internet

My ip route command looks like this:

default via 192.168.0.1 dev eth0
192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.17
192.168.42.0/24 dev wlan0 proto kernel scope link src 192.168.42.1

However, when i set iptables rules on the R-Pi to block a specific site, the request will still go through without being blocked. What can i do to make the iptables rules take effect.

4 added 26 characters in body
source | link

I am working on a network security project that can inspect network traffic before forwarding and accepting traffic from the internet.

I have a R-Pi B+ Model running raspbian stretch lite where the in-built NIC is connected to my ISP router and i also have a wireless USB adapter to create a wireless network where clients can connect to. (Used hostapd and isc-dhcp-server for this). I used this tutorial to set up the R-Pi as a wireless AP https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point?view=all

Here is what my set up looks like:

Smartphone(192.168.42.10) ---> wlan0(192.168.42.1) ---> R-Pi---> eth0(192.168.0.17) ---> ISP Router(192.168.0.1) ---> Internet

However, when i set iptables rules on the R-Pi to block a specific site, the request will still go through without being blocked. Is there anything i am missing here?

I am working on a network security project that can inspect network traffic before forwarding and accepting traffic from the internet.

I have a R-Pi B+ Model running raspbian stretch lite where the in-built NIC is connected to my ISP router and i also have a wireless USB adapter to create a wireless network where clients can connect to. (Used hostapd and isc-dhcp-server for this). I used this tutorial to set up the R-Pi as a wireless AP https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point?view=all

However, when i set iptables rules on the R-Pi to block a specific site, the request will still go through without being blocked. Is there anything i am missing here?

I am working on a network security project that can inspect network traffic before forwarding and accepting traffic from the internet.

I have a R-Pi B+ Model running raspbian stretch lite where the in-built NIC is connected to my ISP router and i also have a wireless USB adapter to create a wireless network where clients can connect to. (Used hostapd and isc-dhcp-server for this). I used this tutorial to set up the R-Pi as a wireless AP https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point?view=all

Here is what my set up looks like:

Smartphone(192.168.42.10) ---> wlan0(192.168.42.1) ---> R-Pi---> eth0(192.168.0.17) ---> ISP Router(192.168.0.1) ---> Internet

However, when i set iptables rules on the R-Pi to block a specific site, the request will still go through without being blocked. Is there anything i am missing here?

3 added 26 characters in body
source | link
2 added 145 characters in body; edited tags; edited title
source | link
1
source | link