I'm trying to install Docker on a Raspberry Pi 3.

I followed the instructions and ran:

curl -fsSL https://get.docker.com -o get-docker.sh
sudo sh get-docker.sh

When I do this, I get the following error:

# Executing docker install script, commit: 2f4ae48
+ sh -c apt-get update -qq >/dev/null 
E: The repository 'https://download.docker.com/linux/raspbian 10 Release' does not have a Release file.

I've tried to modify the docker.list file located at:


The file contains deb [arch=armhf] https://download.docker.com/linux/raspbian 10 stable, but I understand that this file is downloaded/replaced when I run the previous commands. I also took a look at /etc/apt/sources.list but there is just 1 deb and it is related to Raspberry Pi. Nevertheless, commenting it out did not solve anything.

I navigated with my web browser to https://download.docker.com/linux/raspbian and I can see there is a directory there called dists. I tried replacing:

https://download.docker.com/linux/raspbian 10 stable


https://download.docker.com/linux/raspbian/dists/stretch 10 stable

but I just the same no release file error when I try to run sh get-docker.sh again...

Does anyone have any ideas?


I can install Docker using the .deb files but the solution posted on the Docker website is incorrect.

  • "stretch 10 stable" -> stretch is Raspbian 9, 10 is buster.
    – goldilocks
    Commented Jun 26, 2019 at 22:26
  • A couple of days ago I installed the docker enginee and ran the Hello World demo without any problem. ( raspberrypi.stackexchange.com/questions/99843/… )
    – tlfong01
    Commented Jun 27, 2019 at 1:38
  • but the solution posted on the Docker website is incorrect I suggest you notify the people who put that solution on the Docker pages so that they can correct it...
    – Dirk
    Commented Jun 27, 2019 at 7:53
  • If you have solved your problem you should write an answer. This will finish the question and show others that it has a solution.
    – Ingo
    Commented Jun 27, 2019 at 11:57

1 Answer 1


This appears to be an issue with lack of support for Raspbian 10 (buster) on Docker's site, however you can use this workaround for now (worked for me):

sudo curl -sL https://get.docker.com | sed 's/9)/10)/' | sh
  • 3
    I would strongly consider prefixing the URL with https://. Running a script without reading it is one of those cases where you want to at least verify the website's certificate. Commented Jul 4, 2019 at 10:00
  • 6
    I was still getting the same error message. I had to run sudo rm /etc/apt/sources.list.d/docker.list first, then this command. Commented Jul 9, 2019 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.