I am using Raspberry Pi 3 Model B, and installed raspbian-buster on it.

sudo apt-get update works well. But sudo apt-get upgrade shows connection failed.

Err:29 http://archive.raspberrypi.org/debian buster/main armhf arandr all 0.1.9-2+rpt4

Connection failed [IP: 80]

Err:1 http://mirrors.ocf.berkeley.edu/raspbian/raspbian buster/main armhf cron armhf 3.0pl1-134

Connection failed [IP: 80]

Err:30 http://archive.raspberrypi.org/debian buster/main armhf libraspberrypi-doc armhf 1.20190620+1-1

Connection failed [IP: 80]

Err:2 http://mirrors.ocf.berkeley.edu/raspbian/raspbian buster/main armhf libk5crpyto3 armhf 1.17-3

Connection failed [IP: 80]

Err:31 http://archive.raspberrypi.org/debian buster/main armhf libraspberrypi-dev armhf 1.20190620+1-1

Connection failed [IP: 80]


When I pinged to that IP addresses, there was no packet loss.

I tried sudo apt-get clean, but the same problem still occurs.

  • When you say the problem is not solved, do you mean that you still get a failed connection, or that you now have a connection, but the apt system isn't able to recover?
    – user105131
    Commented Jun 26, 2019 at 21:40
  • @BenCrowell Still same problem(connection failed). edited
    – dolgom
    Commented Jun 26, 2019 at 21:54
  • 1
    Unfortunately this is not uncommon just after the Foundation does a major release. Keep trying
    – Milliways
    Commented Jun 26, 2019 at 22:00

1 Answer 1


As Milliways said, it seems because of the problem in the major release.

After I downgrade to Stretch, the 'connection failed' problem does not occur.

  • Please accept your answer with click on the tick on the left side. It finishes the question and will not pop up again months for months.
    – Ingo
    Commented Nov 24, 2019 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.