0

I can print to my wireless printer from my laptop just fine, but I'm having trouble getting it to work from my Raspberry Pi. I found some instructions that said to install cups-client, then edit the cups client.conf file. However, after installing cups-client I didn't have the etc/cups directory. I tried also installing cups and found that the directory was created after that, but I still did not have the .conf file. I found an example file in /usr/share/doc/libcups2/examples and copied it to the cups directory. I then added ServerName [IP of my printer]:631 and tried printing again, but it still didn't work. I tried using lpr but nothing prints, and in LibreOffice the only printer listed is Generic Printer. lpstat doesn't output anything, and when I run lpstat -t I get

scheduler is running no system default destination lpstat: -1 not supported! lpstat: -1 not supported! lpstat: -1 not supported! lpstat: -1 not supported!

Similarly, most other lpstat options give the not supported error. Does anyone know what I'm doing wrong here?

0

I don't have any experience with wireless printing via CUPS, but in the past I've had to setup a driver to get CUPS working over USB.

This page might help: https://www.openprinting.org/drivers. I'd also test connecting it via USB first.

Apologies if I couldn't be of more help. Hoping someone with a bit more experience comes along...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.