4

After switching to Raspbian Buster and rebooting RPi3 B+ boots into a shell. (I use the GUI so this is a bit odd) After typing in startx I get this error (I cutout a bunch of junk):

(EE) no screens found(EE)

(EE) Server terminated with error (1). Closing log file

xinit: giving up

xinit: unable to connect to X server: Connection refused

xinit: server error

Is there any way to fix this?

9
  • Do you have xorg.conf? Have you tried removing it? Commented Jul 1, 2019 at 11:15
  • Graphical GUI works for me on a Pi3B. Was this an upgrade or a clean install? Did you set up your monitor per raspberrypi.org/documentation/configuration/config-txt/video.md and/or raspberrypi.org/forums/viewtopic.php?f=29&t=24679?
    – bls
    Commented Jul 1, 2019 at 22:23
  • It was an in-place upgrade to buster
    – reesericci
    Commented Jul 2, 2019 at 14:38
  • @DmitryGrigoryev Where is xorg.conf located?
    – reesericci
    Commented Jul 2, 2019 at 14:42
  • 1
    It seems that there were a lot of changes between Raspbian Stretch and Buster. The Raspbian folks have suggested that a clean install is a better way to go than doing an upgrade. Is it possible for you to build a clean Buster SD card and move your stuff over to it? That might be more expedient than debugging your current card.
    – bls
    Commented Jul 2, 2019 at 16:14

3 Answers 3

9

I had this problem as well and got around it by manually building and installing the fbturbo module from source after which I had my desktops back

When I tried to to the install the missing package via the command line:

sudo apt-get install xserver-xorg-video-fbturbo

This blew up due to the dependency on xorg-video-abi-23. Looking around with apt-cache I can see the currently install module is xorg-video-abi-24 and xorg-video-abi-23 does not exist. My guess is the version in the repository has dependency issues and will not install due to those problems.

3
  • 1
    This is the correct answer. Not sure why "I don't have an answer I just gave up" is the accepted answer... Commented Apr 14, 2020 at 3:47
  • Had to compile from source https://github.com/ssvb/xf86-video-fbturbo/wiki/Installation
    – Rho Phi
    Commented Dec 12, 2021 at 23:42
  • I can't accept the answer because I didn't try it. I'm not saying that the answer isn't valid @PatrickCook
    – reesericci
    Commented Apr 28, 2022 at 13:59
7

I had the same issue. My root cause was that I forgot to update: /etc/apt/sources.list.d/raspi.list from stretch to buster

sudo apt update reported an additional ~ 200 packages that could be upgraded.

sudo apt full-upgrade completed without error, but alas, still no X server, still no display found in the Xorg.0.log.

But I was now able to install xserver-xorg-video-fbturbo

(It doesn't currently auto-upgrade because it's still marked "testing" in the repository as of 2019-10-12)

I also ran raspi-config to make sure auto-logon to the desktop was enabled (yes, I know, that's a bad idea!)

2019-11-04 Update

Check the contents of this file: /etc/systemd/system/[email protected]/autologin.conf

for

[Service]
ExecStart=
ExecStart=-/sbin/agetty --autologin pi --noclear %I $TERM

Mine was missing pi and was causing my auth.log and syslog to fill up with agetty complaints.

4
  • After 'sudo apt update' apart from ~200 upgrades mentioned above, I had 2 errors as it was not able to resolve those addresses. But I still went ahead with full-upgrade and it worked for me. Commented Jul 27, 2020 at 10:01
  • I ran into the same thing. I needed to edit raspi.list then rerun apt to fix.
    – jjohn
    Commented Apr 28, 2021 at 23:54
  • I had to delete /usr/share/X11/xorg.d/99-fbturbo.conf (or rename) and then startx worked as expected.
    – jjohn
    Commented Apr 29, 2021 at 0:26
  • remove xserver-xorg-video-fbturbo and then reinstall. That seemed to get autologin to work again for me on my rpi3.
    – jjohn
    Commented Apr 29, 2021 at 0:39
1

This is the wrong answer. The top answer seems to be much better, but I won't accept it because I didn't try it.


I eventually just sucked it up and reflashed my SD card with Buster. Wasn't too bad redoing everything

1
  • This is so Windows98 ...
    – Rho Phi
    Commented Dec 12, 2021 at 22:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.