My Raspberry Pi, running Raspbmc, hangs randomly while navigating in the menu/settings.

Any hints what I could check to find out what's happening when it hangs?

  • 1
    Do you have access via SSH? Or any other way of accessing the command line?
    – Jivings
    Jul 11 '12 at 9:01
  • Yes i can SSh into the Pi quite perfectly but i'm not sure where i could possibly find some useful information about what causes it to crash. I'm not completely inexperienced with linux but i'm missing deeper knowledge of the system that would help to debug this.
    – bardiir
    Jul 11 '12 at 12:42
  • 1
    What power supply are you using? Jul 11 '12 at 14:25
  • 2
    Did you ever solve this? Aug 8 '12 at 9:14
  • 1
    Have you tried openelec?
    – Zlatko
    Aug 9 '12 at 7:07

Is it crashing or just hanging?

You can try the top command it will show the usage of your resources

CPU: 34.3% usr 10.8% sys 54.0% nic  0.0% idle  0.0% io  0.1% irq  0.5% sirq
Load average: 5.66 4.22 3.35 4/110 24166

I am using OpenELEC which is oriented on XBMC for small devices, it is not stable yet, but it worth the try (running OpenELEC-RPi.arm-devel-20120914034643-r11925).

I do have small glitches in the navigation menu when the RPi is indexing media files or doing other operations.

The RPi is built to do hardware decoding of specific formats. But since august 24th, if you buy some licenses you can decode MPEG-2 and VC-1 : http://www.raspberrypi.org/archives/1839

Hope this helps

  • Whatever caused the issue for me has been resolved in the latest version of XBMC, but your answer would probably the best starting point to check out whats happening.
    – bardiir
    Jul 7 '13 at 6:37

I was having this same problem when I had an external HD connected directly to the Pi.

I bought a powered USB-hub to connect the HD (and keyboard/mouser) and now it works fine. No hangs.

  • Did your external hard drive have its own power supply, or was it relying on the USB port for all its power?
    – Richard Ev
    Feb 10 '13 at 11:45

I was having the same problem. Turns out that the USB WiFi adapter I had been using was causing problems in the powered USB hub I had plugged into my Raspberry Pi. Removing it fixed all the problems.

  • How were you able to figure out that this was the problem?
    – Richard Ev
    Feb 10 '13 at 11:43
  • 2
    Well, the USB was suspect, since I only had problems with freshly formatted SD cards only after connecting the USB devices. I then kept re-formatting and trying various combinations of USB devices. It would take about 5 days before problems would appear, so this too a while. Finally, I noticed that the USD hub I was using would get abnormally hot when I plugged the WiFi adapter into it. Feb 10 '13 at 15:24

I'm having the same problem, I just recently transferred Raspbmc onto an external hard drive (so the system is on /dev/sda1), the system seemed to be much faster at first, but now after I navigate in the menu (changing screens) once or twice the front end hangs indefinitely.

I can still access ssh without any problems, topdoesn't report anything suspect, xmbc remains at a constant 6-7%.

This is the latest install, it constantly tells me it fails loading autostart.py after boot on xbmc screen, I can navigate the menu about twice and then it fails loading the next screen. It's really strange as it worked fine yesterday, it hanged maybe once, but not systematically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.