2

I am using TightVNC to get into a Raspberry Pi Zero W, running Raspbian.

The pi normally runs headless and I will never attach a monitor to it, only remote in.

When I remote in, I see a small desktop (I would guess 640 x 480), surrounded by black.

How do I see it full screen when VNCing in?

1 Answer 1

2

The -geometry switch on the TightVNC command line will set the geometry as you like it. Where that command actually is depends on how you're starting VNC. Common situations are vncserver, xinetd, or using systemd. I did a write-up on setting up TigerVNC with systemd but can be easily applied to tightvnc. See https://github.com/gitbls/RPiVNCHowTo

5
  • Well, it looks like the -gemotry option applies ot the server, not the client. So, while TightVnc is my client, my server is
    – Mawg
    Commented Jul 4, 2019 at 19:54
  • Correct. The geometry is on the server side. Read the note that I linked to and it should be quite obvious, even if you don’t implement that method for your vnc server
    – bls
    Commented Jul 4, 2019 at 20:03
  • What actually worked for me was Settings/Raspberry Pi Options/System/Set resolution. Thanks for your help. Your guide is excellent
    – Mawg
    Commented Jul 4, 2019 at 20:03
  • 1
    Yes that will do it if you’re using the built-in feature on Raspbian Full. Great you got it resolved!
    – bls
    Commented Jul 4, 2019 at 20:41
  • I will, however, award you the answer, for your great GitHub How-To. Thanks
    – Mawg
    Commented Jul 4, 2019 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.