2

Over the past several days, I have tried and failed to make my raspberry pi recognize the speakers that I connected to it through the 3.5mm jack. The USB microphone that I plugged in works perfectly well and I believe that my sound card is good as well. I have spent these days looking at everything on the internet and nothing has changed. If anyone has any idea what I should do, I would really appreciate it. Thank you!

EDIT: @goldilocks I am using old analog speakers that use the auxilary port. I read several notices about amplifying the speakers, but I don't know anything about it and I am not using any amplifiers as far as I'm aware.

EDIT 2: A very important note is that before I started plugging in speakers and microphones and changing the settings, I remember an "Analog" option for the speakers. However it disappeared and I haven't seen it since.

  • 1
    What do you mean by sound card? – evildemonic Jul 3 '19 at 20:53
  • 3
    Welcome. You should edit in some basic information about the speakers, and how you are amplifying the signal from the jack; there's no amp built into the Pi. – goldilocks Jul 3 '19 at 22:29
0

Question

How to tell Rpi to use the speakers connected to the USB sound stick?

Answer

I am using Rpi3B+ stretch 9 GUI Desktop's automatically installed VLC Media Player.

My speaker is connected to the USB hub.

Method 1

GUI Desktop Top Menu > Preferences > Audio Device Settings > Sound Card >

Choose the following USB audio device, make it default, then OK.

USB Audio Device (Alsa Mixer)

NOT bcm2835 ALSA (Alsa Mixer)

Method 2:

VLC Media Player > Top Menu > Audio > Audio Device

You will see a long list 30+ audio devices. Select the following as default:

USB Audio Device USB Audio Default Audio Device

Tips

If you select USB audio in Raspberry Config, but then BCM something in VLC Player, or vice versa, Rpi might become crazy. So the best thing to do is select USB in both config menus.

| improve this answer | |
  • After some testing in the terminal and checking the settings, it seems that I do not have an "alsa mixer" at all. Also, when I do it through the second method, I only see one device called "Built In Audio Stereo." Also, my speaker is connected to my 3.5mm jack and not a USB port. – Osik Brodsky Jul 4 '19 at 18:25
  • @Osik Brodsky, Thanks for clarification. So you have an USB stick/sound card with two jacks (or just one), and a microphone is connected to the USB stick's mike jack (red), and speaker connected to Rpi board's built in 3.5mm jack. Never mind what is "alsa mixer" for now, I don't understand much about it either. My speaker is just an ordinary cheapy speaker used for PC Windows 7/10. NOW 2 QUESTIONS - (1) Can you test your speaker on Win7/10, to make sure it is good? (2) If your USB sound stick has two jackss, can you try your speaker on the speaker jack (green)? – tlfong01 Jul 5 '19 at 2:20
  • Sorry for the confusion. For the first question, I actually tested the speakers with my phone and they worked fine. For the second question, I think you misunderstood. There aren't any extra attachments and my speaker is connected directly to the 3.5mm jack of the raspberry pi (my model is Rpi 3 B ). – Osik Brodsky Jul 5 '19 at 14:52
  • @Osik Brodsky, Thanks for clarification. Now I know that you have the following setup: (1) USB mike connected to Rpi USB socket, (2), "Speaker" connected to Rpi on board 3.5mm jack. What causes confusion is the following: "The USB mike that I plugged in works perfectly well and I believe that my sound card is good as well, ...". I am not sure is the following: (1) USB microphone is not just a microphone, it has a "sound card" or "half sound card" which Rpi can interface. A USB sound stick has two 3.5mm jacks, one for mike, one for speaker, ie, a "full sound card". / to continue, ... – tlfong01 Jul 6 '19 at 4:45
  • I am so sorry, I misunderstood. I did not understand what a sound card was in the context of the microphone and it turns out that I do not have one at all. Sorry again for confusing you. – Osik Brodsky Jul 7 '19 at 19:23
3

The 3.5 mm jack is an analog output, it doesn't recognize anything. If you are having trouble getting sound out of it, the first thing to try is forcing audio out to the 3.5 mm jack with raspi-config.

In raspi-config, go to advanced, then audio, then select Force 3.5mm ('headphone') jack.

| improve this answer | |
  • 1
    There seems some confusion. I am not sure if the OP's speaker is connected to the Rpi board's 3.5mm jack, OR his USB sound stick's 3.5mm jack. So perhaps he can try all options in $ sudo raspi-config > Advanced Options (7) > Audio (A4) > Choose any of the following 3 options (0) Auto, (1) Force 3.5mm ('headphone') jack, (2) Force HDMI – tlfong01 Jul 4 '19 at 7:36
  • @evildemonic Forcing the audio through the 3.5mm jack was one of the first things that I tried and was unsuccessful. I also tried setting hdmi_drive=2 in the /boot/config.txt. I have also confirmed that it isn't an issue with the speakers themselves by plugging them into various devices and seeing that they work. – Osik Brodsky Jul 4 '19 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.