1

I have a Raspberry Pi 3B+ with Ubuntu-mate 1.20.1 (Ubuntu 18.04.2) that I want to run headless and use VNC and SSH to access. Connections will be via WiFi, and the Pi has a static address on my network. Problem is, the WiFi isn't active until after I log in, and I can't log in without the WiFi being active! How can I activate the WiFi after boot, but before anyone logs in?

1

I did a lot of stuff, including installing all of the updates and changing things in the network manager, and now it seems to be working like it should. I'm not sure what fixed it, but I suspect it was clicking the All users may use this network box, combined with one of the 2 hours worth of updates.

0

You can’t set Ubuntu up without keyboard etc!

Ubuntu has no user account until you set it up.

Configuring Network Manager (assuming Ubuntu MATE still uses it ) from the command line is difficult, but can be done with nmcli.

Once setup it should work (I have done on 16.04)

You would be better to configure Debian networking or install dhcpcd.

  • You could mount the SD card on another linux host, chroot into the SD card, and setup either Network Manager, wpa supplicant or netplan. But if you don't know you could do that, it is unlikely you would know how to do that... – Aron Jul 4 at 3:30
  • the OP is talking about running headless ... not setting up headless ... the OP is saying that networking does not come up before login ... sounds like the networking daemon is started by the user login scripts – jsotola Jul 4 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.