4

The way I setup the RPI is through sharing my laptop's connection via ethernet. I enabled SSH. Now I am trying to SSH from it without being hardwired to it the way I set it up and the connection keeps timing out. While sharing my PC's internet with the RPI I can SSH fine.

So I tried everything in this post: SSH - connection timeout when connecting

  • I can ping it from my PC when I'm on the same network (hotel network), but it gives me "Destination net unreachable", then says that no packets were loss. Now that I'm on a different public network I can't ping it. I just get that the request gets timed out.
  • I set up SSH using raspi-config.
  • I can SSH from the RPI itself.
  • I can SSH from the RPI itself using the actual address and port.
  • I added ports: 80 and 55555.

Any ideas as to what could be the issue? I've read a lot of other posts, but I think I've done most of the tips given. The only thing I'm thinking is the way the hotel network is set up. AP isolation?

  • 1
    I think it's going to be the way the network is setup. Hotel/public networks will be setup to block traffic such as ssh as a security measure. You may be able to get round it using a another port. Or if that doesn't work you could potentially set the pi up as a wifi hotspot and then connect your laptop to the internet via the pi and ssh into the pi. That said again with public wifi they can also set them up to block connection sharing but if it's working from laptop to pi it doesn't sound like that's the case for you. – rohtua Jul 4 at 21:26
  • Is there something I could check to see if it is the network setup? I tried port 80 and 55555, but those didn't work either. And right, I shared my laptop's internet to the RPI initially via ethernet. – El Gallo Negro Jul 4 at 21:43
  • Just the other day I was having an issue with my raspberry pi and hotel WiFi. Does the WiFi require an internet browser login, say with a hotel room number? That (as well as other mentioned issues) could be preventing you from connecting properly. I could never get my pi to pop up the connection request in a browser, when it worked just fine on my laptop. – ConcernedHobbit Jul 5 at 4:56
2

First of all check firewalls. Routers have an option to isolate clients. Check if you have installed ufw and disabled ports. Check if both pc and raspberry pi are in same network. aka network part of ip same. Check if windows is not blocking connections. Now a days windows is preloaded with a restrictive firewall, after smbv1 apocalypse. Check if you can ping each other, if dont work one way try other way. Windows blocks ping by default. Disable firewall or add a rule for ICMP packets. Boot linux [live or installed] in pc and check if linux allows you to connect. If this worked. Culprit is windows firewall. Check file transfer or remote access in general, like host a http server in phone and check.

Hope this helped

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.