0

I am seeing that the thermal throttling doesn't work while you read the frequency from:

/sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq

And thermal information from:

/sys/class/thermal/thermal_zone0/temp

Here's simple Ruby script I wrote: Image

The problem you see, the temperature goes to 71℃ and it's still overclocked. In fact, the frequencies don't reduce even when the pi is running at 80℃.

What's the problem with my pi?

1

Did you change kernel or did avoid_warnings flag in /boot/config.txt (it only disables power warning normally).

If you have compiled a vanilla branch from kernel.org with cherry picked commits from raspbean kernel, it may be missing thermal throttle code.

Which governor are you running.

  • I am just using the Arch-Linux ARM's Kernel, and I don't even have the avoid_warnings flag in the /boot/config.txt... – Sourav Goswami Jul 5 at 5:41
  • It's weird. The ambient temperature here is 40℃. The temperature of the pi goes to 85℃ easily if you are just using the browser, and no thermal throttling can lead to severe damages! – Sourav Goswami Jul 5 at 5:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.