1

I noticed that when the screensaver is activated (Pi4 & Raspbian) the monitor doesn't actually turn off but rather a black picture is displayed. After extensive investigations on Google and in this forum it seems this is something many people are experiencing, also on older models, but none of the remedies suggested anywhere have worked for me.

using "tvservice --off" and "tvservice --preferred" works to manually turn off/on the HDMI but obviously I want the screensaver to activate/deactivate HDMI automatically and enable a true power saving mode.

I have installed xscreensaver (and configured it) plus added hdmi_blanking=1 to /boot/config.txt, but to no effect.

any suggestions?

1
1

It's impossible in Pi4 since hdmi_blanking=1 is not yet implemented.

Ref: https://github.com/raspberrypi/documentation/blob/master/configuration/config-txt/video.md#hdmi_blanking

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.