So, basically I am connecting a Bluetooth earpiece to my RPi 3.B

The problem started when I typed the following in the terminal

sudo bluetoothctl

the following output came

""Waiting to connect to Bluetooth..."" I waited for like 1 hour and nothing happened. I searched the web and according to what a site said I did the following (Not knowing what it meant):

modprobe btusb
sudo bluetoothctl

I dont know what it did, but the same problem occurred.

I also tried opening "Bluetooth manager" In "Preferences", but it said that Connection to Bluez had failed, and that the Bluez daemon is not running and blueman-manager could not run.

I tried re-installing all Bluetooth related packages [bluez, blueman, pi-bluetooth], but nothing happened and the same problem is still occurring

Also I tried

systemctl status blutooth

and the output was

bluetooth.service - Bluetooth Service
Loaded: error (Reason: Invalid argument)
Active: inactive (dead)
  Docs: man:bluetoothhd(8)

Also I have tried disabling and enabling Bluetooth and WI-FI driver on my pi but doesn't help..

Please help, what should I do?

NOTE: There is no problem with my hardware as my WI-FI is working good, and i'm pretty sure that wifi and Bluetooth have the same hardware.(That's what a site told me)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.