0

I would like to install lirc on my raspberry pi 3B+. Unfortunately there is an error message when installing with apt-get.

I just reinstalled raspbian using Noobs to avoid any problems due to changed settings or other installed packages and only executed sudo apt-get update and sudo apt-get upgrade. So without changing anything else, installing lirc with sudo apt-get install lirc -y gives the following output:

enter image description here enter image description here

Any ideas, why the installation crashes and how I can fix it?

Thanks a lot for any help!

5
  • ,I ran "sudo apt-get install lirc -y" without any problem. My config is rpi3B+, stretch 9. I never and did not connect any IR hardware. – tlfong01 Jul 9 '19 at 5:24
  • TobiasM, your error msg is lircd failed "Result: signal", I know nothing about signal, so I have no idea how to troubleshoot. Good Luck! – tlfong01 Jul 9 '19 at 6:30
  • Please don't post pictures of text. Instead paste the text direct into the question. – Ingo Jul 9 '19 at 9:46
  • @TobiasM did you solve this ? I have the same issue with stretch 10 – gfd Jan 26 '20 at 12:19
  • I finally used this tool to receive and send ir codes (search for irrp.py): abyz.me.uk/rpi/pigpio/examples.html As I do not need to send files via infrared, it is possible for me to use this less powerful alternative. Only problem left is that sending ir codes while playing music is not possible (results in short codes), but I guess this is caused by PWM and will persist if I switch to lirc. – TobiasM Jan 27 '20 at 16:36
0

The accepted answer in this post actually give the right procedure to install LIRC:

You need to copy the default configuration file into the right place:

sudo cp /etc/lirc/lirc_options.conf.dist /etc/lirc/lirc_options.conf

Please note that this only allows to install LIRC on Raspberry Pie (Buster) without error but I cannot guaranty that you won't have to perform other configuration operation before IR is fully usable: for more information, please see the SO post and this post

Full detailed documentation about LIRC is available here

-1
  1. sudo apt-get remove lirc
  2. sudo apt-get install lirc
2
  • Please elaborate a bit on why you think that would solve the problem. – Bex Nov 29 '19 at 8:19
  • Although there is no way for you to know this, someone else posted this as an answer as well, then deleted it because it turned out the problem was not solved. However, it is still something that may have worked for others in a similar context. – goldilocks Nov 29 '19 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.